Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM Assets are not visible on Mobile preflight after upload

robinsbadugu
Level 1
Level 1

project insight:

I'm trying to work on AEM and AEM Mobile integration, where i have developed few articles for mobile app using custom template and components which renders images configured from authorable dialogs and some are hardfixed in HTL markup. The mobile app in AEM is configured with AEM Mobile cloud and the developed articles are uploading successfully to the cloud which is also previewed on preflight app.

Issues:

Initially we had issue with styles (clientlibs) which wasn't loading on Mobile end (preflight), so i created configuration in etc/contentsync/template, pointing path to my project clientLibs and after uploading it as shared HTML resources that issue got fixed, while there is still problem with assets which are not getting populated on preflight mobile pages. i've tried similar configs as of clientLibs, using types: assets, image and copy, but it didn't work. Want to know how the images can exported from AEM to AEM Mobile. is there anything needs to be configured or a setting i'm missing.

Note: only the images added on articles using "foundation/component/images" are getting displayed.

Referred links: [1] Mobile with Content Sync, [2] Content Properties

2 Replies
smacdonald2008
Level 10
Level 10

I am checking with customer care to see if this is a known issue.

smacdonald2008
Level 10
Level 10

If you are following the docs exactly and the same results are not rendering - there could be a bug. I am double checking with the team. Can you confirm that you have followed the docs exactly as is?