Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

AEM 6.5 SP1

Avatar

Level 2

We would like to know if anybody come across issue after installing SP1 on AEM 6.5. Issue we are noticing is some core service bundles are not getting

started (Installed State), specifically WCM Projects - Core Bundle (com.adobe.cq.com.adobe.cq.projects.wcm.core) and

We.Retail - Core (com.adobe.cq.sample.we.retail.core)...end result is compilation error in core components when we.retail page is invoked.

Any suggestions or pointers to resolve?

Thanks

1 Accepted Solution

Avatar

Correct answer by
Level 2

Thanks for all the inputs.

I was able to resolve and install SP1 by re-installing base AEM-6.5

View solution in original post

7 Replies

Avatar

Employee

I have done this update and did not see any issues.

try invalidating cache and rebuild libraries:

http://host:port/libs/granite/ui/content/dumplibs.rebuild.html

Avatar

Employee Advisor

Adding to what Hamid has mentioned, try these steps:

- Go to http://localhost:6502/system/console/fsclassloader and click "clear class loader" (top right).

- By default, clientlibs cache is now stored in crx-quickstart/launchpad/felix/bundle<clientlibs-BundleID (com.adobe.granite.ui.clientlibs)>/data/outputcache. Clear the outputcache folder.

- Stop and start bundle org.apache.sling.commons.fsclassloader

Regards,

Vishu

Avatar

Employee

Personally, I have not seen any issue.

Based on your description, there should be some log messages that will help you to narrow down the source of the problem. I would suggest posting some error messages that you are seeing so we can help on the forum. If the issue is more involved with too many problems, I would recommend using a ticket for it.

Avatar

Level 2

Thanks Hamid ,Vishu & SonDang. I did try those suggestions with no luck.

In the error.log what I see is Unable to resolve dependencies exceptions. Pasting here from one of the bundle when I try to Install from console.

19.09.2019 12:19:39.187 *ERROR* [FelixStartLevel] ERROR: Bundle '582' Error starting jcrinstall:/apps/core/wcm/install/core.wcm.components.core-2.3.1-20190213_144341-eea47f4.jar (org.osgi.framework.BundleException: Unable to resolve com.adobe.cq.core.wcm.components.core [582](R 582.3): missing requirement [com.adobe.cq.core.wcm.components.core [582](R 582.3)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.foundation.security)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve com.day.cq.wcm.cq-wcm-foundation [468](R 468.0): missing requirement [com.day.cq.wcm.cq-wcm-foundation [468](R 468.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.core.stats)(version>=5.7.0)(!(version>=6.0.0))) [caused by: Unable to resolve com.day.cq.wcm.cq-wcm-core [465](R 465.7): missing requirement [com.day.cq.wcm.cq-wcm-core [465](R 465.7)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.wcm.ui.components.container.service)(version>=1.0.0)(!(version>=2.0.0)))]] Unresolved requirements: [[com.adobe.cq.core.wcm.components.core [582](R 582.3)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.foundation.security)(version>=1.0.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve com.adobe.cq.core.wcm.components.core [582](R 582.3): missing requirement [com.adobe.cq.core.wcm.components.core [582](R 582.3)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.foundation.security)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve com.day.cq.wcm.cq-wcm-foundation [468](R 468.0): missing requirement [com.day.cq.wcm.cq-wcm-foundation [468](R 468.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.core.stats)(version>=5.7.0)(!(version>=6.0.0))) [caused by: Unable to resolve com.day.cq.wcm.cq-wcm-core [465](R 465.7): missing requirement [com.day.cq.wcm.cq-wcm-core [465](R 465.7)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.wcm.ui.components.container.service)(version>=1.0.0)(!(version>=2.0.0)))]] Unresolved requirements: [[com.adobe.cq.core.wcm.components.core [582](R 582.3)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.foundation.security)(version>=1.0.0)(!(version>=2.0.0)))]

        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)

        at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)

        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)

        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

        at java.lang.Thread.run(Thread.java:748)

Regards,

Avatar

Employee Advisor

Hello,

It means some dependencies are not satisfied. You can use the http://localhost:port/system/console/depfinder to find the dependencies.

What version of the core components is there? Try to get the latest version:

https://github.com/adobe/aem-core-wcm-components/releases/tag/core.wcm.components.reactor-2.6.0

Regards,

Vishu

Avatar

Correct answer by
Level 2

Thanks for all the inputs.

I was able to resolve and install SP1 by re-installing base AEM-6.5

Avatar

Level 3

I am sorry, this can not be the correct answer. Because, in reality, when we see this issue in a validated environment, we cant re-install AEM 6.5 

 

I am looking for a better resolution techniques as we are facing a similar issue on AEM 6.5. Will try depfinder and see if it gives additional information