Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.5 : Oak Index Lucene warnings when performing OOTB asset delete operation on OOTB instance

cquser1
Level 8
Level 8

Hi All,

We started OOTB 6.5 instance without having any custom code deployed. Uploaded an asset into test folder and deleted it. http://localhost:4505/assets.html/content/dam/test ​ .The asset was placed under here and deleted.

We see the below lucene related warnings.

28.06.2019 06:46:14.689 *WARN* [0:0:0:0:0:0:0:1 [1561729574673] POST /bin/wcmcommand HTTP/1.1] org.apache.jackrabbit.oak.plugins.index.lucene.LucenePropertyIndex This index is deprecated: /oak:index/lucene; it is used for query Filter(query=select [jcr:path], [jcr:score], * from [nt:base] as a where contains(*, '"/content/dam/test/test.png"') /* xpath: //*[jcr:contains(., '"/content/dam/test/test.png"')] */ fullText="/content/dam/test/test.png", path=*). Please change the query or the index definitions.

28.06.2019 06:46:15.210 *WARN* [sling-threadpool-711f5004-2f30-4c0d-9171-fb068ae94b84-(apache-sling-job-thread-pool)-8-<main queue>(ref-updater/delete)] org.apache.jackrabbit.oak.plugins.index.lucene.LucenePropertyIndex This index is deprecated: /oak:index/lucene; it is used for query Filter(query=select [jcr:path], [jcr:score], * from [nt:base] as a where contains(*, '"/content/dam/test/test.png"') /* xpath: //*[jcr:contains(., '"/content/dam/test/test.png"')] */ fullText="/content/dam/test/test.png", path=*). Please change the query or the index definitions.

Is it something like in order for this to be fixed, product team will be providing a fix in the near future.

Any thoughts on this will be helpful.

arunpatidar26kautuk sahnigauravb61796566

1 Accepted Solution
hamidk92094312
Correct answer by
Employee
Employee

The query is run every time on deletion of resources. The team is aware of this and a report has already been filed CQ-4272648. This is under further investigation

View solution in original post

13 Replies
hamidk92094312
Correct answer by
Employee
Employee

The query is run every time on deletion of resources. The team is aware of this and a report has already been filed CQ-4272648. This is under further investigation

View solution in original post

sawan051
Level 3
Level 3

Same question, we are on AEM 6.5.6 and still seeing this issue.

19.07.2021 16:28:01.382 *WARN* [10.231.207.176 [1626712080261] GET /mnt/overlay/wcm/core/content/sites/jcr:content/rails/references/items/references.provider.html HTTP/1.1] org.apache.jackrabbit.oak.plugins.index.lucene.LucenePropertyIndex This index is deprecated: /oak:index/lucene; it is used for query Filter(query=select [jcr:path], [jcr:score], * from [nt:base] as a where contains(...
 
This comes up in log every time you try to rollout or view page references. Sometimes process takes upto 2-3 minutes, curious if this is causing performance issue. 
cquser1
Level 8
Level 8

Hi Hamid,

Thank you for the info. That helps.

suryap99159268
Level 2
Level 2

Hi hamidk11679710

When I edit the content fragment inside a content fragment list I am receiving the same WARN as above in my error logs and edited content fragment alone just got disappeared after editing them.

can you suggest something for this, please?

I am unable to access the above JIRA ID as well. is the request closed already? can you please update.

Thank you.

varuns69729001
Level 1
Level 1
We are also facing the same issue. Any update on this issue?
hamidk92094312
Employee
Employee

Hi, The referenced Jira is awaiting prioritization. So its not been closed or released.

suryap99159268
Level 2
Level 2

Hi,

Thank you for the quick response.

Any suggestion for below, please.

When I edit the content fragment inside a content fragment list I am receiving the same WARN as above in my error logs and edited content fragment alone just got disappeared after editing them.

Thank you,

Surya

hamidk92094312
Employee
Employee

Can you clarify if this WARN is causing any performance or functionality issue ? I am not aware of any existing workaround.

suryap99159268
Level 2
Level 2

Note: Content fragment list is accepting only 10 content fragments inside it.

When I try to add more than 10. Last modified content fragment is getting disappeared in the page.

I updated the below scenario.

Yes, Sure.

I am using a content fragment list on my page. I have 11 content fragment inside this content fragment list.

I go to /content/dam/<my-project-path>/content-fragement-1 (one of the 11 content fragments in the list) and edit this content fragment and saved it.

Now edited content fragment alone gets disappeared from the list.

Now I can see only 10 content fragments in the list, not 11.

Any idea on this?

My error log.

*WARN* [0:0:0:0:0:0:0:1 [1565016004677] GET /editor.html/content/dam/<my-project-path>/content-fragement-1 HTTP/1.1] org.apache.jackrabbit.oak.plugins.index.lucene.LucenePropertyIndex This index is deprecated: /oak:index/lucene; it is used for query Filter(query=select [jcr:path], [jcr:score], * from [nt:base] as a where contains(*, '"/content/dam/<my-project-path>/content-fragement-1"') /* xpath: //*[jcr:contains(., '"/content/dam/<my-project-path>/content-fragement-1"')] */ fullText="/content/dam/<my-project-path>/content-fragement-1", path=*). Please change the query or the index definitions.

*WARN* [0:0:0:0:0:0:0:1 [1565016004677] GET /editor.html/content/dam/<my-project-path>/content-fragement-1 HTTP/1.1] org.apache.jackrabbit.oak.plugins.index.lucene.LucenePropertyIndex This index is deprecated: /oak:index/lucene; it is used for query Filter(query=select [jcr:path], [jcr:score], * from [nt:base] as a where contains(*, '"/content/dam/<my-project-path>/content-fragement-1"') /* xpath: //*[jcr:contains(., '"/content/dam/<my-project-path>"')] */ fullText="/content/dam/<my-project-path>/content-fragement-1", path=*). Please change the query or the index definitions.

*INFO* [sling-oak-observation-5] org.apache.sling.event.impl.jobs.queues.JobQueueImpl.<main queue> Starting job queue <main queue>

*INFO* [sling-oak-observation-5] org.apache.sling.event Service [QueueMBean for queue <main queue>,8318, [org.apache.sling.event.jobs.jmx.StatisticsMBean]] ServiceEvent REGISTERED

*WARN* [sling-threadpool-8267dcb0-b529-4e0c-889c-f04364bdb76d-(apache-sling-job-thread-pool)-19-<main queue>(ref-updater/references)] org.apache.jackrabbit.oak.plugins.index.lucene.LucenePropertyIndex This index is deprecated: /oak:index/lucene; it is used for query Filter(query=select [jcr:path], [jcr:score], * from [nt:base] as a where contains(*, '"/content/dam/<my-project-path>"') /* xpath: //*[jcr:contains(., '"/content/dam/<my-project-path>/content-fragement-1"')] */ fullText="/content/dam/<my-project-path>/content-fragement-1", path=*). Please change the query or the index definitions.

*WARN* [sling-threadpool-8267dcb0-b529-4e0c-889c-f04364bdb76d-(apache-sling-job-thread-pool)-19-<main queue>(ref-updater/references)] com.adobe.cq.xf.impl.reference.XfToXfReferenceProvider The resource at /content/dam/<my-project-path> doesn't point to a page

*WARN* [sling-threadpool-8267dcb0-b529-4e0c-889c-f04364bdb76d-(apache-sling-job-thread-pool)-19-<main queue>(ref-updater/references)] com.adobe.cq.xf.impl.reference.PageToXfReferenceProvider The resource at /content/dam/<my-project-path>/content-fragement-1 doesn't point to a page

Thank you.

suryap99159268
Level 2
Level 2

Fixed this problem by updating core component dependency to 2.5.0.

Thank you

sawan051
Level 3
Level 3
I am using core component 2.8.0, still see this issue. Did you do anything else to resolve it?
Mahamood
Level 3
Level 3

I am using AEM version 6.5.2 and still seeing this issue when try to create Content Fragment.

*WARN* [sling-threadpool-a4d71255-ffbc-4303-aef9-ed7d1b918a48-(apache-sling-job-thread-pool)-14-<main queue>(ref-updater/delete)] org.apache.jackrabbit.oak.plugins.index.lucene.LucenePropertyIndex This index is deprecated: /oak:index/lucene; it is used for query Filter(

query=select [jcr:path], [jcr:score], * from [nt:base] as a where contains(*, '"/content/dam/personal_fragments/test"')

/* xpath: //*[jcr:contains(., '"/content/dam/personal_fragments/test"')] */ fullText="/content/dam/personal_fragments/test", path=*).

Please change the query or the index definitions.

This look like trigger from "ref-updater/delete" .