Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.5 login-token 404 issue

Avatar

Level 1

Hello!

 

I'm facing an issue in AEM 6.5. When an user logins to the site everything is working fine, but after a while, the session expires but the login-token cookie session still exist in the browser, causing the user to get 404 (because they are basically an anonymous user attempting to view a page).

 

Is there a "best way" to solve this kind of issues? I've read in the forum sticky sessions in the load balancer or dispatcher, creating a node in the config, but I don't know if I may be missing something that could help me out in this issue.

 

Thank you in advance!

1 Accepted Solution

Avatar

Correct answer by
Level 5

IMO Sticky Session will not work in this case.

Either you need to refresh the authentication token before it expires or you need to gracefully logout the user may be you can redirect the user to homepage once session expires using JS/Jquery this is possible. 

View solution in original post

3 Replies

Avatar

Level 2

is this going through a load balancer or using saml?

There is a way to extend the login token time to something really long but would like to know if something else is timing out

Avatar

Level 1

It's using a load balancer, multiple publish with a dispatcher per publish

Avatar

Correct answer by
Level 5

IMO Sticky Session will not work in this case.

Either you need to refresh the authentication token before it expires or you need to gracefully logout the user may be you can redirect the user to homepage once session expires using JS/Jquery this is possible.