Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM 6.3 upgrade from 6.1 SP1 failed on jboss

Avatar

Level 3

None of the aem pages are accessible, aem error log is not getting generated, lot of bundles dependency errors while starting jboss. can somebody share what is the working procedure to migrate from 6.1 SP1 to 6.3 on jboss.

I have followed the below steps:

1. Copied 6.1 SP1 crx_quickstart(sling.home) repository & datastore

2. Downloaded 6.3 war file and changed web.xml sling.home to 6.1 crx_quikcstart path

3.Deployed modified war file in jboss deployment directory

4.started the jboss

Getting the below exceptions in jboss server log while starting. none of the aem logs are updated in crx_quickstart directory.

 

10:58:06,514 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/wcm-devcloud]] (FelixStartLevel) ERROR: Error starting slinginstall:org.apache.aries.util-1.1.0.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.aries.util [2](R 2.1): missing requirement [org.apache.aries.util [2](R 2.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6)) Unresolved requirements: [[org.apache.aries.util [2](R 2.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))]): org.osgi.framework.BundleException: Unable to resolve org.apache.aries.util [2](R 2.1): missing requirement [org.apache.aries.util [2](R 2.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6)) Unresolved requirements: [[org.apache.aries.util [2](R 2.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
    at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_102]

10:58:06,517 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/wcm-devcloud]] (FelixStartLevel) ERROR: Error starting slinginstall:org.apache.sling.javax.activation-0.1.0.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.javax.activation [3](R 3.0): missing requirement [org.apache.sling.javax.activation [3](R 3.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) Unresolved requirements: [[org.apache.sling.javax.activation [3](R 3.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))]): org.osgi.framework.BundleException: Unable to resolve org.apache.sling.javax.activation [3](R 3.0): missing requirement [org.apache.sling.javax.activation [3](R 3.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) Unresolved requirements: [[org.apache.sling.javax.activation [3](R 3.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
    at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_102]

 

10:58:06,520 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/wcm-devcloud]] (FelixStartLevel) ERROR: Error starting slinginstall:org.apache.sling.settings-1.3.6.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.settings [4](R 4.1): missing requirement [org.apache.sling.settings [4](R 4.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [5](R 5.1): missing requirement [slf4j.api [5](R 5.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))] Unresolved requirements: [[org.apache.sling.settings [4](R 4.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))]): org.osgi.framework.BundleException: Unable to resolve org.apache.sling.settings [4](R 4.1): missing requirement [org.apache.sling.settings [4](R 4.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [5](R 5.1): missing requirement [slf4j.api [5](R 5.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))] Unresolved requirements: [[org.apache.sling.settings [4](R 4.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
    at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_102]

10:58:06,522 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/wcm-devcloud]] (FelixStartLevel) ERROR: Error starting slinginstall:slf4j-api-1.7.6.jar (org.osgi.framework.BundleException: Unable to resolve slf4j.api [5](R 5.1): missing requirement [slf4j.api [5](R 5.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) Unresolved requirements: [[slf4j.api [5](R 5.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))]): org.osgi.framework.BundleException: Unable to resolve slf4j.api [5](R 5.1): missing requirement [slf4j.api [5](R 5.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0)) Unresolved requirements: [[slf4j.api [5](R 5.1)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5.0))]
    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
    at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_102]

0 Replies