Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.2 URL Mapping with Resource Resolver not working

Avatar

Level 2

Hi All,

I have configured my resource resolver as below, Which is working fine, but after deploying the same into 6.2, the urls are not getting truncated in the links (hrefs), It is giving complete path of page like /content/site1/en/home.html, so please help me in this regard, how to fix this.

Here is my config,

<?xml version="1.0" encoding="UTF-8"?> <jcr:root xmlns:sling="http://sling.apache.org/jcr/sling/1.0" xmlns:jcr="http://www.jcp.org/jcr/1.0" jcr:primaryType="sling:OsgiConfig" resource.resolver.allowDirect="{Boolean}true" resource.resolver.manglenamespaces="{Boolean}true" resource.resolver.map.location="/etc/map" resource.resolver.mapping="[/-/,/content/com-blogs/en/(.+)&lt;/$1]" resource.resolver.searchpath="[/apps,/libs,/apps/foundation/components/primary,/libs/foundation/components/primary]" resource.resolver.virtual="[/:/]" resource.resolver.required.providers="[org.apache.sling.jcr.resource.internal.helper.jcr.JcrResourceProviderFactory]"/>

Thanks in Advance.

Stack : JDK 8 + AEM 6.2 

1 Accepted Solution

Avatar

Correct answer by
Level 7

This is a known granite bug, just install this hotfix and it will work. cq-6.2.0-hotfix-11490-1.0.zip. If you don't have this hotfix, you can ask from day care for same or search in adobe package share.

View solution in original post

0 Replies

Avatar

Level 3

Hi Maruti,

Did you get a resolution for the same? We are exactly facing the same issue.

Thanks!

Avatar

Level 2

Hi Maruthi,

Is this issue resolved ? I am also having same issue after migrating to AEM 6.2. Please let me know the solution if you have.

Thanks in advance

Avatar

Level 2

Hi Souradeep, 

Is this issue resolved ? I am also having same issue after migrating to AEM 6.2. Please let me know the solution if you have.

Thanks in advance

Avatar

Administrator

I have asked internal experts to have a look at this one.

~kautuk

Avatar

Correct answer by
Level 7

This is a known granite bug, just install this hotfix and it will work. cq-6.2.0-hotfix-11490-1.0.zip. If you don't have this hotfix, you can ask from day care for same or search in adobe package share.

Avatar

Administrator

Thanks a lot Ankur for the help here.

Here is the link for the HotFix:

             
DateNameFixesComment
August 1st, 2016Hotfix 11490SLING-5622 - Deadlock between service unregisterIncluded in AEM 6.2 SP1

List of all the AEM 6.2 Hotfix can be found here :- https://helpx.adobe.com/experience-manager/kb/aem62-available-hotfixes.html

~kautuk

Avatar

Level 2

Hi Kautuk,

Thanks for the response , I already have SP1 installed which has Hotfix 11490 included but still I am having this issue. 

Below hotfixes are also installed :

1. cq-6.2.0-hotfix-11473-1.0.0.zip

2. cq-6.2.0-hotfix-12785-7.0.zip

3. cq-6.2.0-hotfix-14163-1.0.zip

Avatar

Level 2

Hi Kautuk,

If we compare the Resource resolver factory configurations in AEM6.2 and AEM6.2 SP1 then there is a difference in Required Providers.

AEM 6.2 Required Providers: org.apache.sling.jcr.resource.internal.helper.jcr.JcrResourceProviderFactory

AEM6.2 SP1 Required providers : JCR

Not sure if this is the root cause of the issue.

I have attached the config screenshot from both aem instances.