Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM 6.2 classicui form show/hide not working

Avatar

Level 3

created a form (not adaptive) in 6.2 classic.

create a radio and text field and had a rule in radio to show or hide text field based on radio options using show/hide edit rules.

But doesnt seem to work.

Is there any other thing to be done in order to make this work?

Thank you,

1 Reply

Avatar

Administrator

Moving this to AEM Forms Topic!! Checking Internally!

Avatar

Level 1

kautuksahni  Looks like user created a form (not adaptive). Please move this to sites team so that it can be addressed.

Avatar

Level 10

If you are using sites form - have you tried creating your own form components and adding logic to make it function the way you want? Using JQuery and CSS - you can make this work -- javascript - Hide/Show Form Fields with CSS and jQuery - Stack Overflow

Avatar

Level 3

But why is the OOTB edit rules not working ?

The console is throwing errors with abacus scripts.

TypeError: $(...).abacusLink is not a function

Is there any problems with abacus modules. If I add the validation scripts, the abacus modules fail stating the above error.

I believe the jquery is called twice. Just want to understand if there has been any patches related to forms specially for abacus errors

Avatar

Employee Advisor

Can you place the code snippet of the issue and the error message. I am currently debugging an issue where show/hide is removing the form elements since I change the default DOM structure

Avatar

Level 3

rajeshs28932860​ :

I remember a bug in some version (not sure of the version number though), where if you make the radio button/check box  as mandatory then all the rules used to stop working, it was fixed with an incremental release.

Can you please confirm, if you can reproduce the bug. I mean if this thing does not work only if radio is mandatory, in that case, I can help you find the bug fix (incremental release) for this issue.

Cheers,

Jagjeet Singh

AEM Forms Blog

Avatar

Level 3

Hi jagjeetthukral

I tried creating two text fields and applied rules. It doesn't work on them as well.

Avatar

Level 3

hey, I just realised that you have written its non adaptive form, what kind of form is it then?

Avatar

Level 3

its OOTB form component provided by CQ.

1. if validation is present the form it is not previewed in edit mode or in publish instance. How ever if there is no validation then I am able to preview the form.

2. I get errors in abacuslink function and that is where the validation is failing.