Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.

AEM 6.2 Blog/Journal Extend component - Cant post data and Error - Comment value is empty

Avatar

Level 2

Hello,

I am trying to extend the OOTB blog/journal component. I can click new article on the blog page and add title and message. But once I click on publish I am not able to post the data and ending up getting the error as Comment Value is Empty. When I tried to debug I can see that post operation call is throwing 400 error and input to the post data i.e., title and message are also empty.

I am not doing any heavy customizations for the OOTB component. For the matter of fact I am just trying to see whether I can extend the OOTB component in my local project repository.

I was successfully able to extend the comments component following the adobe documentation -https://docs.adobe.com/docs/en/aem/6-2/develop/communities/tutorials/extend-comments.html. I followed similar approach to extend blog component and was not able to extend. I even looked at the github sample code - https://github.com/Adobe-Marketing-Cloud/aem-scf-sample-components-extension but I was unsuccessful.

I tried all different ways to resolve the issue, but I always ending up not able to post data. When I try to drag and drop the OOTB Blog/Journal component, I am able to successfully post the data and the component works fine. Can someone shows little direction on how I can extend the blog, looks like I am missing something here. 

Your response would be highly appreciated.

Please find the attached screenshot for the errors and below errors found on the log

com.adobe.cq.social.scf.OperationException: Comment value is empty
    at com.adobe.cq.social.commons.comments.endpoints.AbstractCommentOperationService.validatePa rameters(AbstractCommentOperationService.java:1064)
    at com.adobe.cq.social.forum.client.endpoints.AbstractForumOperationsService.validateParamet ers(AbstractForumOperationsService.java:157)
    at com.adobe.cq.social.commons.comments.endpoints.AbstractCommentOperationService.create(Abs tractCommentOperationService.java:881)
    at com.adobe.cq.social.journal.client.endpoints.impl.JournalCommentCreateOperation.performOp eration(JournalCommentCreateOperation.java:84)
    at com.adobe.cq.social.commons.comments.endpoints.AbstractCommentOperation.performOperation( AbstractCommentOperation.java:137)
    at com.adobe.cq.social.scf.core.operations.AbstractSocialOperation.run(AbstractSocialOperati on.java:82)
    at org.apache.sling.servlets.post.impl.SlingPostServlet.doPost(SlingPostServlet.java:202)
    at org.apache.sling.api.servlets.SlingAllMethodsServlet.mayService(SlingAllMethodsServlet.ja va:149)
    at org.apache.sling.api.servlets.SlingSafeMethodsServlet.service(SlingSafeMethodsServlet.jav a:345)
    at org.apache.sling.api.servlets.SlingSafeMethodsServlet.service(SlingSafeMethodsServlet.jav a:376)
    at org.apache.sling.engine.impl.request.RequestData.service(RequestData.java:546)
    

Thanks,

23 Replies

Avatar

Level 9

samikshaj895937 wrote...

Hi , i am also facing the similar issue doing nothing , just dragged and dropped ootb forum component into my page and it gives a number of java script errors .

I actually do not know which clientlibs are missing and what to add to solve this.

 

It is recommended to create your own question and provide details about your environment and how you created your site.

See also documentation for authors and developers.  If you create a community site using the wizard, you can add a Forum function to your site structure.

- JK

Avatar

Level 2

Hi Aponnusa/Kendall,

 

I tried different ways,its not working. I used fresh instance of AEM and just installed the components I shared with you. Still I can reproduce the issue. Are you using an Author instance or Publisher instance? Can you send me a screenshot with your working page. Are you sure its the custom blog you are using instead of OOTB component?

 

Thanks,

Sumeer

Avatar

Employee

Sumeer,

Blog is a publish side component. So I used publisher instance. Despite that it shouldnt matter where you are. Also we recommended you to try the component at /content/community-components/en/journal.html, did you try that ?. When you try at that path, we can isolate if some other client lib is interfering or not. 

 

I have attached my crxde screenshot. As you can see, I am using the custom component you provided.