Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.2 and Java 1.8

sgr_01
Level 2
Level 2

I recently did an in-place upgraded of AEM 6.1 to 6.2. AEM 6.1 used Java 1.7 and during the upgrade to 6.2 Java version stayed the same. The upgrade has been working fine without any issues. Recently the Application Dev team wanted the Java to be upgraded to 1.8. Downloaded the latest JDK and upgraded the Java on the machine. When I try to start the author or the publish the instance won't start and no logs being written to error.log. I see the following error in the stdout.log file. When i revert the java back to 1.7 everything works like a charm. Did anyone experience a similar issue? Appreciate all your help.

28.07.2017 20:46:12.926 *ERROR* [FelixStartLevel] ERROR: Bundle '225' Error starting jcrinstall:/libs/sling/install/30/org.apache.sling.startupfilter.disabler-0.0.1-Rev1387008.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.startupfilter.disabler [225](R 225.0): missing requirement [org.apache.sling.startupfilter.disabler [225](R 225.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=0.0.0)(!(version>=1.0.0))) [caused by: Unable to resolve org.apache.sling.startupfilter [42](R 42.0): missing requirement [org.apache.sling.startupfilter [42](R 42.0)] osgi.wiring.package; (osgi.wiring.package=javax.servlet.http) [caused by: Unable to resolve org.apache.felix.http.servlet-api [29](R 29.2): missing requirement [org.apache.felix.http.servlet-api [29](R 29.2)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7))]] Unresolved requirements: [[org.apache.sling.startupfilter.disabler [225](R 225.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=0.0.0)(!(version>=1.0.0)))])

1 Accepted Solution
Ratna_Kumar
Correct answer by
Community Advisor
Community Advisor

Hi,

Yes, Scott is right.

From AEM 6.2 and above versions, JAVA 1.8 is supported!!

~Ratna.

View solution in original post

10 Replies
smacdonald2008
Level 10
Level 10

Java 1.8 is supported - see this: https://docs.adobe.com/docs/en/aem/6-2/deploy/technical-requirements.html#Java Virtual Machines

Test on a fresh AEM install to see if you have any issues with 1.8 and AEM 6.2. I suspect issue is with upgraded version.

Ratna_Kumar
Correct answer by
Community Advisor
Community Advisor

Hi,

Yes, Scott is right.

From AEM 6.2 and above versions, JAVA 1.8 is supported!!

~Ratna.

View solution in original post

sgr_01
Level 2
Level 2

I knew Java 1.8 was supported but my question was a little different. I upgraded AEM to 6.2 with Java 1.7. After the upgrade now i am trying to upgrade to Java. When i do that and try to restart either the author or publish nothing happens and no update in the log files. So what i wanted to know was should the Java be upgraded at the same time as i did AEM. Is there some dependency on class files or jar files. Our environment is a stand alone implementation. It does not run on any container.

Ratna_Kumar
Community Advisor
Community Advisor

Hi,

Do you see any errors in Java classes. Ideally there will be issue with Java classes if you upgrade to 1.8.

Some classes won't support. Please let us know, if you see any errors.

~Ratna.

sgr_01
Level 2
Level 2

This is what i see (pasted above as well)

*ERROR* [FelixStartLevel] ERROR: Bundle '225' Error starting jcrinstall:/libs/sling/install/30/org.apache.sling.startupfilter.disabler-0.0.1-Rev138700 8.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.startupfilter.disabler [225](R 225.0): missing requirement [org.apache.sling.startupfilter.disabler [225](R 225.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=0.0.0)(!(version>=1.0.0)) ) [caused by: Unable to resolve org.apache.sling.startupfilter [42](R 42.0): missing requirement [org.apache.sling.startupfilter [42](R 42.0)] osgi.wiring.package; (osgi.wiring.package=javax.servlet.http) [caused by: Unable to resolve org.apache.felix.http.servlet-api [29](R 29.2): missing requirement [org.apache.felix.http.servlet-api [29](R 29.2)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.7))]]

Jörg_Hoh
Employee
Employee

Hi,

Can you please post the system properties [1] from the affected instance? It looks like that the instance does not run on Java 1.7, but on an older version. Can you confirm, that the bundle version of "Apache Felix Servlet API" is 1.1.2?

[1] http://localhost:4502/system/console/status-System%20Properties

sgr_01
Level 2
Level 2

Removing the following line in sling.properties fixed the issue.

org.osgi.framework.system.capabilities=${eecap-${java.specification.version}}

Jörg_Hoh
Employee
Employee

Hi,

I don't have this parameter in my local 6.2 installation. Have you added it yourself?

kind regards,
Jörg

sgr_01
Level 2
Level 2

That was available in version 6.1 of the sling.properties.

Jörg_Hoh
Employee
Employee

Ah, right. Haven't thought of it yet. Would you mind to create a Daycare ticket and report this finding? It might be included then in the update documentation.

Thanks for reporting back,

Jörg