AEM 6.1: Back-end Developer Workshop -Video Training Sample Project Maven Error

Avatar

Avatar

ian_liszewski

Avatar

ian_liszewski

ian_liszewski

05-05-2016

I am currently taking the AEM 6.1 Back-end Developer Training course and I am stuck on the section "AEM 6.1 Back-end Developer Workshop", video "Installing and Configuring Eclipse". The video told me that if I was still having issues with maven at that point in the video then I needed to come to the forums for assistance. So here i am.

I tried to run "mvn clean install" on the practice project and got a bunch of maven dependency errors. Next the video told us to change the maven settings.xml file to add in a profile for adobe to access the public adobe maven repository. The settings file - which the video told us to add - was not in the student training files that were attached to the video. Therefore I found it online and added this profile to the xml file within <profiles></profiles>:

"<profile>

        <id>adobe-public</id>

        <activation>

            <activeByDefault>false</activeByDefault>

        </activation>

        <properties>

            <releaseRepository-Id>adobe-public-releases</releaseRepository-Id>

            <releaseRepository-Name>Adobe Public Releases</releaseRepository-Name>

            <releaseRepository-URL>http://repo.adobe.com/nexus/content/groups/public</releaseRepository-URL>

        </properties>

        <repositories>

            <repository>

                <id>adobe-public-releases</id>

                <name>Adobe Public Repository</name>

                <url>http://repo.adobe.com/nexus/content/groups/public</url>

                <releases>

                    <enabled>true</enabled>

                    <updatePolicy>never</updatePolicy>

                </releases>

                <snapshots>

                    <enabled>false</enabled>

                </snapshots>

            </repository>

        </repositories>

        <pluginRepositories>

            <pluginRepository>

                <id>adobe-public-releases</id>

                <name>Adobe Public Repository</name>

                <url>http://repo.adobe.com/nexus/content/groups/public</url>

                <releases>

                    <enabled>true</enabled>

                    <updatePolicy>never</updatePolicy>

                </releases>

                <snapshots>

                    <enabled>false</enabled>

                </snapshots>

            </pluginRepository>

        </pluginRepositories>

    </profile>"

Next I ran the command mvn clean install -P full and I still received a dependency error, only this time there were less Errors. Here is the error message in the console:

"C:\VideoTraining\company\sampleproject>mvn clean install -P full

[INFO] Scanning for projects...

[WARNING] The POM for com.day.jcr.vault:maven-vault-plugin:jar:0.0.6 is missing,

no dependency information available

[ERROR] [ERROR] Some problems were encountered while processing the POMs:

[WARNING] 'groupId' contains an expression but should be a constant. @ ${project

.parent.groupId}:${module.prefix}-core:[unknown-version], C:\VideoTraining\compa

ny\sampleproject\company-core\pom.xml, line 9, column 11

[WARNING] 'artifactId' contains an expression but should be a constant. @ ${proj

ect.parent.groupId}:${module.prefix}-core:[unknown-version], C:\VideoTraining\co

mpany\sampleproject\company-core\pom.xml, line 10, column 14

[WARNING] 'groupId' contains an expression but should be a constant. @ ${project

.parent.groupId}:${module.prefix}-ui:[unknown-version], C:\VideoTraining\company

\sampleproject\company-ui\pom.xml, line 9, column 11

[WARNING] 'artifactId' contains an expression but should be a constant. @ ${proj

ect.parent.groupId}:${module.prefix}-ui:[unknown-version], C:\VideoTraining\comp

any\sampleproject\company-ui\pom.xml, line 10, column 14

[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:maven-vault-plug

in:0.0.6 or one of its dependencies could not be resolved: Failure to find com.d

ay.jcr.vault:maven-vault-plugin:jar:0.0.6 in https://repo.maven.apache.org/maven

2 was cached in the local repository, resolution will not be reattempted until t

he update interval of central has elapsed or updates are forced @

@

[ERROR] The build could not read 1 project -> [Help 1]

[ERROR]

[ERROR]   The project com.adobe.training:company-ui:0.0.1-SNAPSHOT (C:\VideoTrai

ning\company\sampleproject\company-ui\pom.xml) has 1 error

[ERROR]     Unresolveable build extension: Plugin com.day.jcr.vault:maven-vault-

plugin:0.0.6 or one of its dependencies could not be resolved: Failure to find c

om.day.jcr.vault:maven-vault-plugin:jar:0.0.6 in https://repo.maven.apache.org/m

aven2 was cached in the local repository, resolution will not be reattempted unt

il the update interval of central has elapsed or updates are forced -> [Help 2]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit

ch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please rea

d the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildin

gException

[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/PluginManagerE

xception

C:\VideoTraining\company\sampleproject>"

I am unsure of how to fix this error. Could someone please assist me? Thank you.

View Entire Topic

Avatar

Avatar

rampai

Avatar

rampai

rampai

28-03-2017

Thanks. It worked!