Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.0 Developer tools for Eclipse not working for existing maven project

Avatar

Level 4

Hi All,

I converted existing maven project to Sling Bundle project using  right click it in the Project Explorer and Select Configure -> Convert to Sling Bundle Project.
Now, I did some change in a file and on save it getting deploy on AEM instance where I can see the updated time of bundle in AEM console but code is not getting updated on AEM instance. Because of this if I am putting some checkpoint, I am not able to debug the code as well.

But if manually I upload bundle in AEM instance via mvn clean install, code is getting updated and working.

Could anyone help with this ?

Thanks 

1 Accepted Solution

Avatar

Correct answer by
Level 10

This question comes up a lot. Eclipse plugins are third party and may have bugs. You can sync code between AEM and Eclipse using vault. See this community article for details 

https://helpx.adobe.com/experience-manager/using/creating-aem-project-using-eclipse.html

View solution in original post

1 Reply

Avatar

Correct answer by
Level 10

This question comes up a lot. Eclipse plugins are third party and may have bugs. You can sync code between AEM and Eclipse using vault. See this community article for details 

https://helpx.adobe.com/experience-manager/using/creating-aem-project-using-eclipse.html