Layout not appearing on device

JorgeRivero

21-01-2016

Hi,

I have created an app for Android and I have designed a 768 x 1024 layout using the Layout Templates Beta, I have assigned the layout to my collection, after republishing everything I have downloaded and signed the app, but when I open the app in my device, 1) It opens the first article instead of the layout.  2) The layout is not shown, I just see a list of titles. Maybe I'm missing something? I have to mention that I'm testing the app in a much smaller screen. I will really appreciate any help.

Thanks

Jorge

Accepted Solutions (0)

Answers (2)

Answers (2)

JorgeRivero

22-01-2016

Hi Colin,

Thank you so much for your reply! You are absolutely right. I had the default top-level with the default layout, I have added the main collection into the top-level and it works.

Thank you again.

Jorge

Colin_Fleming

22-01-2016

Hey Jorge;

There may be many details involved here, so I'm guessing...

Does your project have one or two Top-Level navigation systems?

- If you have two, your device may be small enough to be a "phone" and will get the content in default phone instead of default tablet.

What's in the top-level for your project?

- This is what's shown on first launch. If you have an article as the first content in your top-level then that's what you'll see instead of a collection displayed as a browse page.

And here's a really important question... You mentioned that you published something.

- What did you publish? The Collection? The Layout Template? Both?

-- Publishing talks to a "production app" -- one that will go to a store. And it takes 3-5 minutes for publishing to finish.

-- Take a serious look at the preflight workflow. It uses either the generic DPS Preflight app that's in the store or an app you build with preflight enabled. Preflight typically takes 20-30 seconds to complete. This is much faster and creates a happier experience.


HTH -- Colin