Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

iOS App Binary Rejected -- App failed to launch on iPad w/ iOS 9.2.1

ritc68433496
Level 2
Level 2

I recently submitted an iOS update to the Apple app store and received an error message telling me that the app binary was rejected.

The error message says that on an iPad running iOS 9.2.1 the app displayed a loading screen but then quit unexpectedly before getting to the home screen of the app.

I have installed a recent iOS test app on an iPad running iOS 9.2.1 and I cannot replicate the problem...it seems to load to the home screen normally.

Here is a screenshot of the error report from the app store:

     Screen Shot 2016-01-27 at 10.36.41 AM.png

13 Replies
Bob_Bringhurst_
Employee
Employee

Have you published your layouts and collections? One possibility is that your test app has preflight enabled. The distribution app displays only published content.

jerwarren
Level 2
Level 2

In my experience, this is likely a signing problem... If the build is preflight enabled, the app doesn't crash, it shows a 'no content' message.  Same with unpublished content.

However, I've seen this happen when using the signing tool to sign a build with an expired cert. It will appear to launch but then immediately crash.

ritc68433496
Level 2
Level 2

The test app does have preflight enabled, however, my layouts and collections are published. We have a working app on appstore with published content. This was just supposed to be an update to the icon, iOS splash screens, and the app description on the app store.

ritc68433496
Level 2
Level 2

The problems I have had with expired certs have all shown up when I tried to use the App Signing Tool. I redid my certs this time because I had one that was expired, but after that I had no problem signing the app and submitting the app. It is a good idea though, and unless someone has some experience with it crashing like this then I will probably just rebuild it in the portal, resign it, and resubmit a new version to the appstore.

RichinZ
Level 3
Level 3

I got this today: Screenshot 2017-02-21 13.11.15.png

None of my certs have expired. I was trying to update my app to the latest build that was released last week.

Bob_Bringhurst_
Employee
Employee

This doesn't seem like a problem with certificates. Have you tested your app on an iPhone? If your app works fine on an iPhone, you might want to resubmit the app.

RichinZ
Level 3
Level 3

It works fine on my iPhone 7+ but I'm not on a IPv6 network.

sftrane
Level 1
Level 1

You're not the only one having this issue. Here's a link to another post on these forums with the same problem: https://forums.adobe.com/message/9004922#9004922. There was no solution found for that post, just a bunch of responding with Apple until they approved it in the state it was in.

Was there ever a solution found for you guys? I received the same rejection notice from Apple today, so I am trying to figure out the proper way to get around it.

This definitely seems like a bug in AEM Mobile. I can replicate it every time on my iPhone 7+ & iPad Mini 2 (both running iOS 10.2.1). Steps to replicate:

1) Uninstall the app

2) Install the app

3) Launch the app

4) Don't touch anything (well if you get the notifications pop-up, you can hit ok on that)

See my video of the issue for reference here: AEM Mobile issue - YouTube

The app will not load any of the .article files until I swipe to switch to the next .article in the app. Then suddenly it will decide to start downloading the files from AEM Mobile's servers, and it works like normal.

Do any of the Adobe employees here on the forums have any suggestions? Is there a way I can file this as a bug?

sftrane
Level 1
Level 1

Bob Bringhurst, do you have any thoughts regarding my previous reply? This issue definitely seems to be with AEM Mobile.

Not sure if any of the other Adobe employees on this forum (Vinod Tanwar  Matthew Laun​) would have any ideas either...it seems like messaging Apple and saying "it's fine, just approve it" isn't the right approach to fixing the underlying problem.

MatthewLaun
Employee
Employee

Shawn,

The problem you've demonstrated in the video link has nothing to do with the topic here about Apple's incorrect iPV6 rejection messages. I'm sure we can help you get your problem resolved. Please contact our support team using the information in the Support tab of the AEM Mobile on-demand portal. If you don't have access to that tab, ask one of your master admins for the account.

Matthew

sftrane
Level 1
Level 1

Matthew,

Thank you for your reply. However, the reason I am posting here is that the rejection message I received from Apple appears to state that IPv6 issues are to blame.

Screen Shot 2017-03-29 at 08.15.47.png

Just thought you should know, since other AEM Mobile devs may end up with the same rejection message from Apple and find this forum (like I did). I will still try your suggestions to contact the AEM Mobile support team for help on this issue, but it seems odd that Apple's suggestions to fix the problem are all IPv6-related.

MatthewLaun
Employee
Employee

It is unfortunate that Apple has been incorrectly reporting iPV6 compatibility issues in their review process. This is not limited to AEM Mobile or Adobe apps. It includes natively built apps from various other developers also. See my post here for more details:

Re: Apple Rejection - Content failed to load on an IPv6 WiFi Network

RichinZ
Level 3
Level 3

I submitted another version a month or two after this build and got it approved. So they’re definitely inconsistent.