Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Unable to create LCA file

yada_deloitte
Level 3
Level 3

Hi,

i am unable to create lca file from workbench. I get the below error. We are using AEM 6.3

1778611_pastedImage_0.png

Also, I get the following error frequently too.

1778618_pastedImage_1.png

Thanks,

Aj

1 Reply
Mayank_Gandhi
Community Advisor
Community Advisor

There can be many reasons, let's start with below 3 questions:

1. Is it happening with all the application or only a few?

2. Furnish complete environment details with OS, App server, cluster/standalone, DB details.?

3. Are the application or server upgraded from previous versions.?

-Mayank Gandhi

yada_deloitte
Level 3
Level 3

Hi Mayank,

1) Its happening with the application where I have forms, images, assets but no process.

2) on Linux OS, JBOSS, Standalone, Oracle DB

3) We are using 6.3

Mayank_Gandhi
Community Advisor
Community Advisor

check if you are able to access http://host:port/lc/crx/de/index.jsp ,  use admin as user and admin as password

Mayank_Gandhi
Community Advisor
Community Advisor

what's the default port of the server? Have you update the default password of the administrator ?

Please share the server logs while the LCA creation fails.

yada_deloitte
Level 3
Level 3

Default port is 8080 and didn't change the default password of the administrator yet. I will share the logs next time LCA creation fails.

Mayank_Gandhi
Community Advisor
Community Advisor

Sure. That will help. Hope you have whitelisted the Hostname in CSRF filter(core settings of adminui)

yada_deloitte
Level 3
Level 3

Not sure. How do I make sure that the host name is white listed in CSRF filter?

Mayank_Gandhi
Community Advisor
Community Advisor

Go to  Administration Console, click Settings > User Management > Configuration > Configure Allowed Referer URL’s. The Allowed Referer list appears at the bottom of the page.

  1. To add an allowed referer:
    • Type a host name or IP address in the Allowed Referers box. To add more than one allowed referer at a time, type each host name or IP address on a new line.
    • In the HTTP Port and HTTPS Ports boxes, specify which ports to allow for HTTP, HTTPS, or both. If you leave those boxes empty, the default ports (port 80 for HTTP and port 443 for HTTPS) are used. If you enter 0(zero) in the boxes, all ports on that server are enabled. You can also enter a specific port number to enable only that port.
    • Click Add.
  2. To remove entry from the Allowed Referer list, select the item from the list and click Delete.If the Allowed Referer List is empty, the CSRF feature stops working and the system becomes insecure.
  3. After changing the Allowed Referer list, restart the server.
yada_deloitte
Level 3
Level 3

Hey, Errors are back.

1783025_pastedImage_0.png

And also, I have sent you the server logs in private message.

Mayank_Gandhi
Community Advisor
Community Advisor

Is it happening with one application or all? Same application which is failing can you tell me the size of all the assets?

yada_deloitte
Level 3
Level 3

I initially thought it has something do with the size of the assets but looks like its not. I was trying to create a patch lca file and this thing happened. Then, after that no matter what I try I get the error. Then, I tried just two xdp templates, it worked (size:75kb). Then with four xdp's I get the error. Do you know what exactly workbench is trying to do here? is it failing to retrieve the xdp files from the repository or any of the assets?

Mayank_Gandhi
Community Advisor
Community Advisor

The assets are synced with Repository, so if the application already exists it will update the assets otherwise it will upload the assets.

Go to crx/de and navigate to /content/dam/formsanddocuments and look for the folder with the same application name as workbench.

yada_deloitte
Level 3
Level 3

Got it. I checked crx/de and all the assets are available, so while uploading assets to create LCA file, this error occurs. Will you guys be able to figure out what the problem is as per the logs that I have shared?

Mayank_Gandhi
Community Advisor
Community Advisor

I am still expecting details on whether this occurs on a single application or all the application. As you mentioned this happens specific to 2 xdp have you tried removing those and tested creating an LCA?

yada_deloitte
Level 3
Level 3

Hey Mayank,

Can you help me in resolving this issue? This happens more often now. No matter what template or how many templates.

Regards

Aj

yada_deloitte
Level 3
Level 3

It happens to the application where I have all the forms, images, schema files etc. it is not specific to any xdp templates, it is specific to the number of templates. No matter what XDP files I choose to create a patch lca for, if its more than 3 files, it fails.