Highlighted

Sample for integrating drafts & submissions component with database

Avatar

Avatar

ivank87588001

Avatar

ivank87588001

ivank87588001

02-04-2017

Hi,

My project's requirements are to save data to a database, i have create a simple registration adaptive form and follow the instructions on the link below

https://helpx.adobe.com/aem-forms/6-2/integrate-draft-submission-database.html

 

Upon submitting the data i got the following error

{"code":"ALC-FMP-001-001"}

Please see attachment for exception found in the error log, any help is appreciated

Thanks,

 

 

Replies

Highlighted

Avatar

Avatar

MaxBarrass

Avatar

MaxBarrass

MaxBarrass

03-04-2017

Try creating a 

Ivan Khong wrote...

Hi,

My project's requirements are to save data to a database, i have create a simple registration adaptive form and follow the instructions on the link below

https://helpx.adobe.com/aem-forms/6-2/integrate-draft-submission-database.html

 

Upon submitti ng the data i got the following error

{"code":"ALC-FMP-001-001"}

Please see attachment for exception found in the error log, any help is appreciated

Thanks,

 

  1.  
  2.  

 

 

Does this happen on publish?

Do you have reverse replication agent setup?

Try creating a reverse replication agent on publisher called "outbox".

Highlighted

Avatar

Avatar

ivank87588001

Avatar

ivank87588001

ivank87588001

03-04-2017

        Hi MaxBarrass, I have not test this on the publish instance yet. I am testing this on the author instance first. I forgot to add the datasource and now it can write to database. however, the data submitted twice on button click,  i found 2 records in "additionalMetaData" table and "metadata" table., but  the  "data" table is emptied. The submission component indicated that there are two submmited forms, but when i click on "submission" tab there is no form listed. There were no exception thrown, but i checked the browser console, it showed that   "item.formName is undefined". I checked the "addionalMetadata" table in MySQL and the formName column is not emptied. Thanks, Ivan