Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Hidden fields are visible in AEM 6.3

Avatar

Avatar
Validate 1
Level 2
hitesh_m
Level 2

Likes

3 likes

Total Posts

40 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
hitesh_m
Level 2

Likes

3 likes

Total Posts

40 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
hitesh_m
Level 2

30-06-2017

Hi,

We are in a process of migrating AEM forms 6.1 to AEM 6.3. We recently encountered one issue that all the fields which we made hidden in 6.1 are visible in 6.3.

We used Visibility expression to make them hide. When we see in the rule editor - the rule is set correct. Any information ?

Replies

Avatar

Avatar
Boost 50
Level 5
James_R_Green
Level 5

Likes

52 likes

Total Posts

191 posts

Correct Reply

47 solutions
Top badges earned
Boost 50
Validate 25
Validate 10
Validate 1
Boost 5
View profile

Avatar
Boost 50
Level 5
James_R_Green
Level 5

Likes

52 likes

Total Posts

191 posts

Correct Reply

47 solutions
Top badges earned
Boost 50
Validate 25
Validate 10
Validate 1
Boost 5
View profile
James_R_Green
Level 5

01-07-2017

Hi,

Out of curiosity, does this issue occur when the rule is in the visual editor and if you change it to the code editor?

Avatar

Avatar
Validate 1
Level 2
hitesh_m
Level 2

Likes

3 likes

Total Posts

40 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
hitesh_m
Level 2

Likes

3 likes

Total Posts

40 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
hitesh_m
Level 2

05-07-2017

We did not change the rules in the editor. We migrated forms from 6.1 to 6.3. However we are getting following JS error - not sure if its related to this problem

TypeError: Cannot read property 'id' of undefined

    at child.handleAccessibility (guideRuntime.js:21263)

    at child.tempXfaFixes (guideRuntime.js:20420)

    at child._newWidget (guideRuntime.js:20471)

    at child._initOrUpdateWidget (guideRuntime.js:21217)

    at HTMLDivElement.<anonymous> (guideRuntime.js:21231)

    at Function.each (en.js:2)

    at n.fn.init.each (en.js:2)

    at child.createWidget (guideRuntime.js:21230)

    at child._syncGuideNodeToHtml (guideRuntime.js:20250)

    at child.postInitialize (guideRuntime.js:20164)

Avatar

Avatar
Give Back 25
Level 5
TundraSteve
Level 5

Likes

51 likes

Total Posts

442 posts

Correct Reply

57 solutions
Top badges earned
Give Back 25
Give Back 10
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Give Back 25
Level 5
TundraSteve
Level 5

Likes

51 likes

Total Posts

442 posts

Correct Reply

57 solutions
Top badges earned
Give Back 25
Give Back 10
Give Back 5
Give Back 3
Give Back
View profile
TundraSteve
Level 5

29-11-2017

Can you export the form and send it to me if there is nothing proprietary?  I'll review it