Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!
SOLVED

Getting Build error during adding the AEM forms core components

Avatar

Level 4

Followed this link to enable the form core components:
https://experienceleague.adobe.com/docs/experience-manager-cloud-service/content/forms/setup-configu...

After getting this build issue.

com.adobe.aem:core-forms-components-af-core:2.0.18: Bundle core-forms-components-af-core:2.0.18 is importing package(s) [com.adobe.aemds.guide.common, com.adobe.aemds.guide.model, com.adobe.aemds.guide.service, com.adobe.aemds.guide.utils] in start level 20 but no bundle is exporting these for that start level.

aravindS_0-1687548831858.png

Thanks in advance

1 Accepted Solution

Avatar

Correct answer by
Level 4

We need to add the following dependency in repo pom. 

<dependency>
<groupId>com.adobe.aem</groupId>
<artifactId>aem-forms-sdk-api</artifactId>
<version>2023.06.19.00-230400</version>
</dependency>

and check the includeFormsenrollment=y in archetype.properties file.

Thanks

View solution in original post

3 Replies

Avatar

Employee Advisor

core components are automatically enabled in the latest version of AEM Forms CS. any reason you cannot use the AEM Forms CS latest build?

Avatar

Level 4

Initially we did only sites, there is no forms addon and forms core component. So now we added the forms addon and dependency for forms core component. Requirement is to use the Adaptive Form Container V2. That time we are getting this issue. Please share is there any best way to add those components. Thanks

Avatar

Correct answer by
Level 4

We need to add the following dependency in repo pom. 

<dependency>
<groupId>com.adobe.aem</groupId>
<artifactId>aem-forms-sdk-api</artifactId>
<version>2023.06.19.00-230400</version>
</dependency>

and check the includeFormsenrollment=y in archetype.properties file.

Thanks