Highlighted

Error when binding to model and submitting

ayecona

03-09-2019

ok so when not biding everything works on this form. but the minute I bind the form to a model. it gives me the following error

1826775_pastedImage_0.png

on the form I bind the field to the model

1826777_pastedImage_2.png

then I go into the designer to add the binding manually. to then upload it into the AEM system as a template and replace the template with the new one

1826776_pastedImage_1.png

However on the previous version of AEM 6.4 i was able to download the DOR (xdp file) and the bidings where already place there. that is how i found out the dor works with the form.

what is wrong with it?

Replies

Highlighted

ayecona

04-09-2019

update:

workflowuserMayank Gandhi

so I found out that if I change the binding to another field it will work. so I don't think the problem is on the adaptive form. I think the problem is on the xml of the template for the DOR. it will not accept $.pcx_case.pcx_anumber no matter where I put it. but if I put other binding on the field it is ok.

so I cannot use that $.pcx_case.pcx_anumber binding because I get the error:

The SOM expression '$.pcx_case.pcx_anumber' for the dataRef specified on field 'numbers', resolved to an incompatible node type of 'dataGroup'.</m >

please help

Highlighted

workflowuser

Employee

04-09-2019

at a huevel can you please explain what you are trying to do?

also send me your pdf form, not the xfa version

Highlighted

ayecona

04-09-2019

workflowuser

I am trying to bind my fields into the DOR.

the way I created the DOR was in designer 6.5 I imported an existing pdf and created an XDP template of it. there were errors like fonts substitutions but that was all I used the default fonts.

then this DOR xdp template I am using with my adaptive form. all other fields are binding well but for some reason the $.pcx_case.pcx_anumber does not and give me the error mention above.

how do i send you xdp template?