Highlighted

Auto save functionality not working

JatinG

12-12-2016

Hello All,

I am trying to use default auto save feature in AEM forms but its not working as expected. As per my opinion if auto save is enabled, then even on browser refresh, the form must retain the information. But this is not happening, even if I checked the auto save option both for anonymous as  well as signed in user.  Although, I can see the data being saved under metadata folder but the form is not populating. 

Any suggestions.

Replies

Highlighted

gauravahuja11

12-12-2016

Hi, If the data and metadata are being stored in the drafts node, then the auto save functionality is configured correctly. You're refreshing the adaptive form window that has the adaptive form url, but this url is only for the form and does not contain any information about how to prefill the form. It wont open a form with the saved values. To open a saved form (i.e. draft), normal refresh won't work. You will have to open the draft from the location where the drafts/submissions on your system are stored. By default, the location for drafts/submissions is - http://:/content/geometrixx-gov/en/applications/myforms.html .

Highlighted

anu_jain

12-12-2016

Hi Jatin,

From your post it looks like metadata is being saved from the autosave feature, could you please confirm whether the data is getting saved or not, userdataID property would be present in the metadata node if data was saved properly.It would be of great help if you could give us some information for the below questions

    1. Set up information and event based or time based autosave is being used.

    2. Confirm if data is being saved or not along with metadata by checking userdataID and manually checking user data folder.

    3.If data is present also then does it throw any error while rendering the draft ? attach the logs if available.

Thanks,

Anul

Highlighted

JatinG

12-12-2016

Hi Anul,

1. Configuration is Time based

2. userDataId exists for each node under /drafts/metadata

3. No error is being seen either on console or logs

When I am using the metadata path as URL to render the form, the empty form is rendered.

Highlighted

JatinG

12-12-2016

Hi Gaurav,

Even I am trying to use metadata path as URL to pre-populate the form, the empty form is getting rendered.

Highlighted

JatinG

12-12-2016

Hi Gaurav,

Even I am trying to use metadata path as URL to pre-populate the form, the empty form is getting rendered.

Highlighted

DarrenBiz

17-07-2018

As gauravahuja11 mentioned above, you can't just hit the adaptive form URL and expect your previously auto-saved data to come back. The saved data is saved per instance of the form being rendered, so if you refresh your browser, you will get a new instance of the form, which will be blank. You also can't use the metadata path as the pre-population service, since the system doesn't know which instance of the form you want (there can be many saved instances of the same form)

You need to use the Forms Portal [1] to let the user select the form that was saved as Draft, then the underlying system will recover the form instance with its data that was saved.

[1] Adobe Experience Manager Help | Introduction to publishing forms on a portal