Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.

AEM Form upgrade to 6.0.914 gives error in existing site pages for Adaptive forms: Caused by: java.lang.NullPointerException: null \tat com.adobe.aemds.guide.common.GuideContainer.createGuideInitializationState(GuideContainer.java:1000)

Avatar

Level 1

AEM on SP 6.5.16.0

applied aem-service-pkg-6.5.16-NPR-40173-B02

and then installed

adobe-aemfd-linux-pkg-6.0.914. (author running on linux)

Restarted author

navigated to a page where the adaptive form embedded using AEM Forms component.

Tried to edit the page: it shows "Error during include of 'libs/fd/af/components/aemform'

Server error.log shows:

 

Cannot get DefaultSlingScript: org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: org.apache.sling.api.scripting.ScriptEvaluationException: 

at org.apache.sling.scripting.core.impl.DefaultSlingScript.service(DefaultSlingScript.java:510) [org.apache.sling.scripting.core:2.3.2]

- - -

Caused by: java.lang.NullPointerException: null

at com.adobe.aemds.guide.common.GuideContainer.createGuideInitializationState(GuideContainer.java:1000) [com.adobe.aemds.guide.aemds-guide-core:6.0.528]

at com.adobe.aemds.guide.common.GuideContainer.getGuideInitializationState(GuideContainer.java:1047) [com.adobe.aemds.guide.aemds-guide-core:6.0.528]

0 Replies