Error in Upload Asset Action. Create Asset Servlet called with format=json AEM 6.2

Avatar

Avatar
Level 1
priyan77466183
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile

Avatar
Level 1
priyan77466183
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile
priyan77466183
Level 1

21-02-2017

Has anyone faced this issue - 

Inside Asset Share page, on using the Upload Asset Action component, it throws this error - Error: SyntaxError: Unexpected token < in JSON at position 72

On looking at this further, it posts the request to http://server:port/content/dam/sample.createasset.html?format=json

and though the upload is happening successfully, the json response from the CreateAssetServlet is malformed, ie html gets appended to the json response.

Please see the screenshot..

 

 

Also asked here : http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/aem-assets.to pic.1_ciot.html/forum__ehwv-has_anyone_facedthi.html

Replies

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,200 likes

Total Posts

6,394 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,200 likes

Total Posts

6,394 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

22-02-2017

Hi 

Moving this thread to AEM "Asstes" topic so to have better contextual experts have a look at this.

~kautuk