Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Adobe Premiere Elements 14 Has Stopped Working on Windows 10

mercerik
Level 1
Level 1

I purchased Adobe Photoshop Elements 14 & Adobe Premiere Elements 14 bundle for Windows on 10/19/2015 for my YouTube videos and has not been able to use it since the installation because of issues with the Premiere Elements 14. Each time I tried to open it an Error Message comes up: Adobe Premiere Elements 14 has stopped working. This morning I tried to solve the problem by going to the website. I didn't find anything that is related to my problem so I uninstalled the software thru the Control Panel and tried to re-install to but it failed. Downloading already takes forever before you can extract it. It is getting into my nerve already so I tried to call the Customer Service toll-free number so I can get the Technical Support Department but the Automated Voice said that there is no phone support for Premiere Elements. What kind of business do they have here? This is not a cheap product and they don't provide phone support at all. Has anyone of you experience this Error Message and were you able to fix the issue?

Message was edited by: MERCEDES FOGELSTROM

9 Replies
þorsteinnj27331
Level 1
Level 1

Hi

Have you been able to fix this problem, I´m having the same issue?

uic66
Level 1
Level 1

I have exactly the same issue.  Photoshop Elements works but not Premiere Elements.  I am returning the product and buying something else.

2stealthy
Level 1
Level 1

Same issue.  Photoshop Elements works but not Premiere Elements

Found this, but did not help;

https://helpx.adobe.com/elements-organizer/kb/Elements-applications-do-not-launch-on-Windows-10.html

Uninstalled everything, re-downloaded, re-installed but Premier Elements throws the error;

Adobe Premiere Elements 14 has stopped working

and on the splash screen is "loading importerquicktime.prm"

Also downloaded/installed the latest QuickTime because of the above.


Anyone find a fix yet ?


mitchj83798137
Level 1
Level 1

adobe premiere elements 14 has stopped working

exactly what mine says and can't find help anywhere ... oh, adobe, what a dissapointment

2stealthy
Level 1
Level 1

Have you tried this ...https://helpx.adobe.com/elements-organizer/kb/Elements-applications-do-not-launch-on-Windows-10.html‌   it did not work for me ...

Not sure if anyone has contacted Adobe yet or just posting in the forums ...

þorsteinnj39808
Level 1
Level 1

I finally got this working by adding a new user to my computer.

Intermediate troubleshooting

4. Install in a new user account.

    

Create a user account that has the same permissions as the account that you use when the problem occurs. If the problem doesn't recur, the original user account could be damaged. For instructions on creating a user account, see Create a new user or contact your system administrator.

Troubleshoot installation | Adobe Photoshop Elements & Adobe Premiere Elements for Windows

2stealthy
Level 1
Level 1

Well that worked ...  Thank you ...


I already had a 2nd user created.  I Signed out of my user, signed in with the other and it fired up.

This is a good Work-Around, but it would be nice to fix the problem ... 

2stealthy
Level 1
Level 1

I found a 'fix' ...

Something else I noticed about my computer was that I could not download anything to the default location of C:/Users/xxxxx - with the error saying you do not have rights ....

I started playing with the "Properties" of the Documents folder and no matter what I did I could not gain actual rights to it.

What I did to 'fix' was to;

   Rt. Click -> Properties  (Documents folder)

   "Location" tab     - - it displayed C:\Users\xxxxx\Documents

   CHANGE that to C:\Users\xxxxx\New Folder   (this is just temporary)

         Windows will ask you if you want to MOVE all contents, say YES..

Now, test Elements and it should work (did for me at least)

Lastly, if you are like me, I want things the way they should be so I re-did the steps above and changed the location back to C:\Users\xxxxx\Documents and tested Elements again and it still works.

GOOD LUCK and feel free to ask any questions.

uic66
Level 1
Level 1

Thanks for sharing this.

I wonder if their is a solution for Windows 7. The steps you prescribe lead me to a documents folder where you are pointing (c:/Users/xxxx/Documents) but when I right click I don't see the "Location " tab.