Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Preview Email Template error

anumola8359486
Level 2
Level 2

Hi ,

While  previewing email template I am getting the below error

Error while evaluating document

PostgreSQL error: ERROR: table "wkdlv_1666572_399fe" does not exist

SQL statement 'DROP TABLE wkDlv_1666572_399fe' could not be executed.

PostgreSQL error: ERROR: table "wkdlv_1666572_399fe_excl" does not exist

SQL statement 'DROP TABLE wkDlv_1666572_399fe_Excl' could not be executed.

Can anyone help me to understand the cause of this error.

Regards,

Anumol Antony

6 Replies
florentlb
Level 10
Level 10

Hi,

Can you specify the version of Campaign that you are using, and provide some more details about where this is happening? Is it a delivery that is part of a workflow? Is there any special field in the content of the email?

If you have some screenshots to share too, that can help.

Let me know,

Florent.

anumola8359486
Level 2
Level 2

Hi ,

The version is AC 6.1.1 build 8724

We are just creating an Email Delivery template and doing a preview . One note is that we do not have mid sourcing enabled in our Environment.

If we open any out of the box  email delivery template and preview the same then also we are getting the same error.

Adhiyan
Employee
Employee

Hi Anumol,

Looking at the error it looks like the template/delivery you are trying to preview has been previously used in a workflow etc. The reason is the table "wkdlv_1666572_399fe" only comes when a delivery has been analyzed and is the name given to the temporary table created during delivery analysis. Now after the delivery analysis this table gets dropped and no longer available in the DB.

Please make sure , you have not copied this delivery from another workflow and then trying to preview it.Also , try and create a new delivery from scratch and then try to preview it and it should work fine

Regards,

Adhiyan

anumola8359486
Level 2
Level 2

Hi  Adhiyan,

Thank you for the response.

I have tried creating a new delivery template and I still get the same error while I do the preview. Also I could notice that any out of the box template in AC if I try to preview also I get this error.

Regards,

Anumol Antony

Adhiyan
Employee
Employee

Hi Anumol,

Can you please share the client console version as well.

I just tried to preview a OOTB delivery template in build 8724 and it worked fine.

Adhiyan

anumola8359486
Level 2
Level 2

Hi Adhiyan,

The version is 6.1.1 build 8724. The preview is working fine in our STG and PROD env , the problem is only with DEV Env.

Thanks and Regards,

Anumol Antony