Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Visits and other traffic metrics but no page views?

toddc59244792
Level 2
Level 2

Hi!

I recently implemented 2 new suites (for new sites) in my Adobe Analytics account, but for some reason they arent receiving page views?

All other standard traffic metrics such as visits, visitors, bounce rate, etc. are working fine, however every day has 0 page views on both suites.

Using Dynamic Tag Manager for implementation, do I need to define a rule within DTM for them to pass into AA?

All of my rules are firing and recording fine as well, I just cant figure out why it says i have 0 page views while I have several hundred visits a day.

1 Accepted Solution
Abhijeet_Mishra
Correct answer by
Employee
Employee

This looks like a standard situation of only s.tl() call being implemented and not a s.t() call.

Please check the server call and see if all of them have the 'pev' parameter. If yes, then that's an s.tl() call. These calls even if have Page related info, no page related attributes like PageName, Pageviews etc. are recorded as s.tl() is by default considered a link track call and not a page OnLoad call.

If above proves true for your implementation, check your DTM setup and ensure you are using s.t() for PageLoad.

View solution in original post

4 Replies
pabloc82923542
Level 9
Level 9

Are you collecting the pagname variable in your data request when capturing analytics? Is it defined in the data layer?  Maybe a beacon output will help troubleshoot the issue.

toddc59244792
Level 2
Level 2

The page name variable is defined in the data layer.

pabloc82923542
Level 9
Level 9

Can you copy the beacon output or a debugger print out of said pageload? Anonymize the url or pagename if its of concern.

Abhijeet_Mishra
Correct answer by
Employee
Employee

This looks like a standard situation of only s.tl() call being implemented and not a s.t() call.

Please check the server call and see if all of them have the 'pev' parameter. If yes, then that's an s.tl() call. These calls even if have Page related info, no page related attributes like PageName, Pageviews etc. are recorded as s.tl() is by default considered a link track call and not a page OnLoad call.

If above proves true for your implementation, check your DTM setup and ensure you are using s.t() for PageLoad.

View solution in original post