Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Help needed : Visit number 1 yielding maximum conversions

ash_muk
Level 1
Level 1
Hey Experts!!

 

I write to you with a specific problem that has been taking over my mind since days now. I have tried to troubleshoot it and look at it from various angles but i am unable to find the answer. I know it is not right but cannot pinpoint the root of the issue.
 
My client is in the industry of education , it is a university to be precise. As per SiteCatalyst , the maximum conversions(form submits) are happening in visit number 1 . This seems very odd to me , since the conversion cycle for an education provider would be more than first visit by a prospect. One usually does some comparison shopping between universities before one decides to pay an application fee. 
 
The visit number is based on the visitor id  so i checked the s_vi cookie for this client(which is a first party cookie) and it is persisting since the first visit , so its not really dropping a  new cookie every time. I tried through multiple browsers and different devices and the cookie persists if i have been through the same browser. What is interesting is that the visit number 1 visits are more than the return visits which ideally should never happen ( the reverse is still okay i believe but not this phenomena).
 
Of course there is multi-browsing and multi-device activities happening and people can delete their cookies too but 92% of conversions coming from visitnumber 1 is strangely odd to me. I checked some other clients on SiteCatalyst (retail , insurance) and they too have the maximum conversions coming in visit number 1. Am i not reading the report correctly? What am i missing?
 
Any direction will be very helpful. There are not many blog posts about visit number too...so i believe sharing the true benefits of this report will be helpful for all of us web analytic professionals too. 
 
Thanks!!

Ashmita

1 Accepted Solution
Gigazelle
Correct answer by
Employee
Employee

This was a known issue that was fixed in our last maintenance release.

View solution in original post

1 Reply
Gigazelle
Correct answer by
Employee
Employee

This was a known issue that was fixed in our last maintenance release.

View solution in original post