Adobe Analytics mbox-contents.js script error in IE11

Avatar

Avatar
Validate 10
Level 3
manovinayaka757
Level 3

Likes

26 likes

Total Posts

54 posts

Correct reply

4 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 25
View profile

Avatar
Validate 10
Level 3
manovinayaka757
Level 3

Likes

26 likes

Total Posts

54 posts

Correct reply

4 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 25
View profile
manovinayaka757
Level 3

16-08-2017

Hi,

The following error happens in Internet explorer and not in any other browser.

SCRIPT5007: Unable to get property 'expires' of undefined or null reference

File: mbox-contents-asdasdasd-staging.js, Line: 8, Column: 2658

The error occurs at this function when the page loads.

function T(t){if("number"==typeof t.expires){var e=new Date;e.setMilliseconds(e.getMilliseconds()+864e5*t.expires),t.expires=e}

We are DTM + Adobe Analytics. has anyone solved this issue, please share how to solve this.

1.JPG

Regards,

Mano

Replies

Avatar

Avatar
Coach
Employee
Gigazelle
Employee

Likes

473 likes

Total Posts

1,947 posts

Correct reply

740 solutions
Top badges earned
Coach
Contributor 2
Validate 1
Ignite 80
Ignite 70
View profile

Avatar
Coach
Employee
Gigazelle
Employee

Likes

473 likes

Total Posts

1,947 posts

Correct reply

740 solutions
Top badges earned
Coach
Contributor 2
Validate 1
Ignite 80
Ignite 70
View profile
Gigazelle
Employee

17-08-2017

mboxes are part of Adobe Target, not Adobe Analytics. Does your organization use Adobe Target?

Avatar

Avatar
Validate 10
Level 3
manovinayaka757
Level 3

Likes

26 likes

Total Posts

54 posts

Correct reply

4 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 25
View profile

Avatar
Validate 10
Level 3
manovinayaka757
Level 3

Likes

26 likes

Total Posts

54 posts

Correct reply

4 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 25
View profile
manovinayaka757
Level 3

17-08-2017

You are absolutely correct. Yes, I missed to mention it.

We are using target as well.

Last month I took the at.js 1.0.0 version and updated it, in the Target configuration section, in DTM as shown in the below.

I pasted the at.js code in the editor (clicked on the 'Open Editor' link as shown below).

target_at_js.JPG

Is there something else which I need to do. Am I missing something?

Avatar

Avatar
Level 1
soniacp
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile

Avatar
Level 1
soniacp
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile
soniacp
Level 1

06-10-2017

Hi Mano

Did you resolve the issue? We are facing the same problem. Anyone that have faced and resolve this problem?

Thank you in advance,

Sonia

Avatar

Avatar
Coach
Employee
Gigazelle
Employee

Likes

473 likes

Total Posts

1,947 posts

Correct reply

740 solutions
Top badges earned
Coach
Contributor 2
Validate 1
Ignite 80
Ignite 70
View profile

Avatar
Coach
Employee
Gigazelle
Employee

Likes

473 likes

Total Posts

1,947 posts

Correct reply

740 solutions
Top badges earned
Coach
Contributor 2
Validate 1
Ignite 80
Ignite 70
View profile
Gigazelle
Employee

03-04-2018

Can you try updating to the latest version of target, analytics, and experience cloud ID service? I am pretty sure the issue has been resolved in our recent appmeasurement library versions.