Expand my Community achievements bar.

Do you have questions about the migration to Adobe Business Platform? Our experts will be answering your questions starting TOMORROW at 8 AM PST!
SOLVED

No filter for a null numeric field ?

Avatar

Level 6

Hi. My users want to filter for Request Records where a numeric field is Null. There doesn't seem to be that option in the new filter interface. I had to switch to the legacy interface to accomplish the filter. Is this intentional or still a work in progress? 

 

Mylah_0-1684878411883.png

(Please note this is a Custom Form field called Request ID and not one of the native fields that comes with Workfront).

 

Thanks.

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Nevermind. I got the same thing to happen on my browser just by making my browser window frame smaller. Every time the dropdown drops "up", I lose half my settings. So yeah... just go straight to the helpdesk with that one.

View solution in original post

7 Replies

Avatar

Community Advisor

I'm interested to hear from others on this, I hope null is planned to work in.

I wonder if for this instead of using legacy could you use 'is less than' 0 - something that is essentially null?

If this helped you, please mark correct to help others : )

Avatar

Community Advisor

field format.jpgnumber field filter.jpg

 

I'm not sure if I interpreted your question correctly, so included a few sample screenshots. Here is a text field that I have set up as a number format, and here is the filter I am creating based on that field. I see an "is/is not blank" option on my side -- are you not seeing these or do you prefer the null/not null options (I think these might come with a differently formatted field?)?

 

If you're not seeing that, I would try deleting cache and cookies first but ultimately try and document it and send it to the helpdesk.

Avatar

Level 6

Thanks, @skyehansen . By all accounts, I should be seeing the big list of filters you're seeing, but I'm not. I only have the few filters. I'll document and let WF Support know. Will come back to let everyone know if clearing cache does the trick. 

Avatar

Community Advisor

Yeah I’m not seeing all of those options with my number format custom form field either. I know in beta WF was prioritizing native fields and gradually bringing in all custom form fields, I wonder if this is a result of that. Let us know what Support says!

If this helped you, please mark correct to help others : )

Avatar

Community Advisor

I see in your screenshot, the dropdown is a "drop-up" so maybe some of your fields are being hidden by the way the web page was configured. Helpdesk should be able to verify.

 

Oh, that reminds me -- do check and make sure you are zoomed in at 100%. Helpdesk does not support any other zoom setting, at the moment.

Avatar

Correct answer by
Community Advisor

Nevermind. I got the same thing to happen on my browser just by making my browser window frame smaller. Every time the dropdown drops "up", I lose half my settings. So yeah... just go straight to the helpdesk with that one.

Avatar

Level 6

Yep! Thanks. I did clear my cache and had the same issue. Will be opening a ticket for this. I've taken a recording of the behavior so - just in case anyone comes up with the same question, here is the behavior I'm describing: