Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Wrong Operand Type Error Message - please help

Not applicable
I have built a form and I keep getting the message - Wrong Operand Type every time I either try to preview or save to PDF as the file suddenly becomes 90% blank (I can see the content boxes for any date fields in the form and if I click the highlight fields option I can see place holders for all of the content) but other than that it wont process properly. I have tried going through the document and made sure that item by item the fields are all inline with each other, have the same fonts, etc. I even tried deleting out every single item in the form, previewing it, then placing that item back in and moving on to the next to try a process of elimination to see if I could figure out what item(s) were causing the problem, but still no luck.



Please help.



CG
7 Replies
Not applicable
Did you ever get an answer to this problem? I have the same issue and can't figure out what I've done wrong.



Please share the knowledge if you've been enlightened.



Thank you!
Not applicable
I have also encountered this problem. Has anyone resolved this issue, or are people simply finding some other obscure work around?
gkaiseril
Level 7
Level 7
This sounds like a problem with rendering of the PDF. Have you tried to save the form, close LiveCycle Designer and then open the form with Acrobat?
Not applicable
I opened the document in Acrobat Reader 7.0. This is when I receive the wrong operand type error. I'm hoping to find some tool that will help me find specifically what is wrong with the document, a debugging tool of sorts. Does anyone know if such a tool exists for PDF documents?
fayeorr
Level 1
Level 1

I, too, am having this error message. I read somewhere that it is either because of the font Helvetica Nueue, or because the files is being shared between a PC and a Mac. The quickest fix I have found, is to take the pdf and open it in Illustrator and convert all the text to curves. Then it should work correctly.

I don't think anyone has found a definitive answer.

thanks

HaarikMFWA
Level 1
Level 1

I had this problem on a indesign file designed by someone else. So i opened the file in indesign & selected all element in a page (Ctrl+A) and carefully unselected each visible and required elements. Atlast one null element remained. But i don't know what it is yet, as i'm not the original designer of the indesign file. I deleted the unkown null object. And it worked fine...

DiacriticalOne
Level 1
Level 1

Just happened to me on a current Adobe Acrobat DC Pro... Could not even print. Opened in Illustrator, saved as PDF and it's all better. Just FYI. Could not get inDesign to load it.