Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Why I am getting "Fail to load data" error?

Avatar

Level 7

Hi Please let mi know why I am getting below error.

akshaybhujbale_0-1670338257599.png

 

 

18 Replies

Avatar

Community Advisor

Hi @akshaybhujbale 

 

Can you please let us know what error you are getting in the error.log? You can also check if you have permission to the node that you are trying to access.

 

Thanks,

Kiran Vedantam.

Avatar

Level 7

Hi @SantoshSai 

We are not getting exactly how to relate that with our error. Can you please set up a call if possible?

Please let me know?

Avatar

Level 5

Hello @akshaybhujbale 

 

Are you noticing the error, only on a specific path in the repository? If yes, there might be corrupted content in that location.

 

Example: in my previous project, the content structure of few CF was incorrect. That caused issues, when we were trying to open the parent folders.

Avatar

Employee

@akshaybhujbale Try removing it. And if it is the culprit, may be you will have to validate your application of granite:AuthenticationRequired. I am sure you must be getting something in error logs for "Failed to Load" Exception

Avatar

Level 7

Hi @krati_garg 

Thanks for your reply 

Will you not down the steps I should follow.?

Also where I can check the logs.?

Avatar

Employee

At first, please check the error Logs. 

For your local AEM Set Up, you can find all sorts of log files in crx-quickstart folder, which is parallel to your quickstart jar:

aem6.x\crx-quickstart\logs

Please mention AEM Version and if it is AEM Enterprise (On Prem) Or AEMaaCS (Cloud Service) @akshaybhujbale 

Avatar

Employee

hi @akshaybhujbale ,

 

Did you find anything in error.log file. Also, you can find whether some nodes are missing jcr:content node.

 

1) Navigate to http://localhost:4502/libs/cq/search/content/querydebug.html

2) On the left side, please paste these parameters

path=/content/dam
type=dam:Asset
nodeExists.notexists=jcr:content

p.limit=-1

 

or 

path=/content
type=cq:Page
nodeExists.notexists=jcr:content
p.limit=-1

Avatar

Level 7

Hi @Nikita___Garg 

That page has jcr:content node that I have checked. Also in error logs I am not getting anything like error or fail to load.

what may be the issue then?

Avatar

Community Advisor

Hi @akshaybhujbale , Can you please post error logs ? Just wanted to see if it points to something specific.

Also can you please add what AEM version you are using? If using AEM cloud sdk, can you try to use latest sdk?

 

When is the error pop up showing up, is it when you reach the experience folder or some other step?

 

Shubham

 

 

Avatar

Level 7

hi @Shubham_borole 

I have checked in the error logs but not getting anything specific to that error.

I am using AEM 6.5 version. On premise

akshaybhujbale_0-1670386447915.png

When I am clicking on Asia cup cricket for its child pages at that point I am getting that error.