Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Not able to build code using maven command

rockstar234
Level 1
Level 1

I am not able to build code using maven command  mvn clean install  and getting below error 

 

[ERROR]

[ERROR]   The project com.myorg.aem:myorgaem.ui.apps:0.0.1-SNAPSHOT (C:\Users\sampleuser\myproject\ui.apps\pom.xml) has 2 errors

[ERROR]     Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved:
 Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2: 
 Could not transfer artifact com.day.jcr.vault:content-package-maven-plugin:pom:1.0.2 from/to adobe-public-releases 
 (http://repo.adobe.com/nexus/content/groups/public):  sun.security.validator.ValidatorException: PKIX path building failed:
 sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 2]

[ERROR]     Unknown packaging: content-package @ com.myorg.aem:myorgaem.ui.apps:[unknown-version], C:\Users\sampleuser\myproject\ui.apps\pom.xml, line 34, column 16

[ERROR]

[ERROR]   The project com.myorg.aem:myorgaem.ui.content:0.0.1-SNAPSHOT (C:\Users\sampleuser\myproject\ui.content\pom.xml) has 2 errors

[ERROR]     Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved:
 Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2:
 Could not transfer artifact com.day.jcr.vault:content-package-maven-plugin:pom:1.0.2 from/to adobe-public-releases
 (http://repo.adobe.com/nexus/content/groups/public): sun.security.validator.ValidatorException: PKIX path building failed:
 sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 2]

[ERROR]     Unknown packaging: content-package @ com.myorg.aem:myorgaem.ui.content:[unknown-version], C:\Users\sampleuser\myproject\ui.content\pom.xml, line 34, column 16

 

on Line no. 34 I have 

<packaging>content-package</packaging>

 

In main pom.xml for Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 I have 

 

<plugin>

                    <groupId>com.day.jcr.vault</groupId>

                    <artifactId>content-package-maven-plugin</artifactId>

                    <version>1.0.2</version>

                    <configuration>

                        <targetURL>http://${aem.host}:${aem.port}/crx/packmgr/service.jsp</targetURL>

                        <failOnError>true</failOnError>

                        <userId>${vault.user}</userId>

                        <password>${vault.password}</password>

                    </configuration>

                </plugin>

 

also tried to with 

<failOnError>false</failOnError> but getting the same error.

 

 

1 Accepted Solution
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

It seems you are not able to connect to adobe repo, could you please try from browser

https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1....

 

and change your setting.xml to use adobe repo with https

https://repo.adobe.com/nexus/content/groups/public/

 

 

View solution in original post

3 Replies
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

It seems you are not able to connect to adobe repo, could you please try from browser

https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1....

 

and change your setting.xml to use adobe repo with https

https://repo.adobe.com/nexus/content/groups/public/

 

 

View solution in original post

gargrohan
Level 2
Level 2
Hi @Arun_Patidar, I am able to connect to adobe repo and have in my settings.xml https based URL. Still I am getting the same error.