Expand my Community achievements bar.

Radically easy to access on brand approved content for distribution and omnichannel performant delivery. AEM Assets Content Hub and Dynamic Media with OpenAPI capabilities is now GA.

Bundle [core-bundle] is importing package(s) com.adobe.fd.workspace.service.external in start level 20 but no bundle is exporting these for that start level.

Avatar

Level 3

Hi all,

Am seeing this error when am trying to build my project . am trying to read the adaptive form’s submitted data is in xml format using 

WorkitemUserMetadataService

have imported the following package.

import com.adobe.fd.workspace.service.external.WorkitemUserMetadataService;

 added dependency as follows in main/core pom xmls as follows:

 

<dependency>

    <groupId>com.adobe.aemfd</groupId>

    <artifactId>aemfd-client-sdk</artifactId>

    <version>6.3.0</version>

    <scope>provided</scope>

</dependency>    

                                                                                                                     

and main pom.xml:

<dependency>

    <groupId>com.adobe.aemfd</groupId>

    <artifactId>aemfd-client-sdk</artifactId>

    <version>6.3.0</version>

</dependency>

 

Can someone provide solution on how to resolve this. I've tried everything I've seen but nothing seems to fix it.

 

Thanks in advance.

7 Replies

Avatar

Community Advisor

@kavalidurga In 6.5 AEM i recommend below dependency 

 

<dependency>
<groupId>com.adobe.aemfd</groupId>
<artifactId>forms-sdk</artifactId>
<version>6.5.0</version>
<scope>provided</scope>
</dependency>

Avatar

Level 3

@Jagadeesh_Prakash  thanks for reply.

 

am using AEM as cloud service.

will this dependency work?

Avatar

Level 3

@Jagadeesh_Prakash  no luck it didn’t work.

Dependency 'com.adobe.aemfd:forms-sdk:cloud' not found
Inspection info:
Reports resolution problems in a Maven model

Avatar

Community Advisor

Hi @kavalidurga ,

Can you compare your pom dependency with the below and check what is missing. Below for version variable you can use yours.

    <dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>aem-forms-sdk-api</artifactId>
            <version>${aem.forms.sdk.api}</version>
        </dependency>
        <dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>core-forms-components-apps</artifactId>
            <type>zip</type>
            <version>${core.forms.components.version}</version>
        </dependency>
        <dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>core-forms-components-core</artifactId>
            <version>${core.forms.components.version}</version>
        </dependency>

 

Avatar

Level 3

@TarunKumar @Jagadeesh_Prakash  

 

Screenshot 2023-03-13 at 4.14.41 PM.png

[ERROR] The analyser found the following errors for author and publish : 

[ERROR] [api-regions-exportsimports] project.core:0.0.1-SNAPSHOT: Bundle core:0.0.1-SNAPSHOT is importing package(s) com.adobe.fd.workspace.service.external in start level 20 but no bundle is exporting these for that start level. (project.all:0.0.1-SNAPSHOT)

getting above error after adding all the dependencies mentioned above,build is failing  . 

Avatar

Community Advisor

@kavalidurga 

Seems the package is not available as a bundles so can you try reffering to below URL 

 

https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/getting-error-while-buildi...