Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

Upgrading from LiveCycle ES4 to Adobe Experience Manager Forms

Avatar

Level 1

Hello,

I need to find someone in Poland that help company, that i work for, to upgrading/migrating from LiveCycle ES4 to Adobe Experience Manager Forms.

 

Regards,

Waldek

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Level 3

Waldek,

 

I cannot recommend anyone nor do it myself but I can give you some lessons from experience.

I have migrated existing applications, forms, assets, etc. from LiveCycle ES2 to ES3, ES3 to ES4, and AEM 6.4 to 6.5.

One of those migrations was an attempt by an on-premises server and admin team to upgrade. It was a disaster. We ended up spinning up new servers, loading the next version of LiveCycle and moving existing applications and assets from the older version using LCA's (we just did work on the JEE side at that time).

The 6.4 to 6.5 migration was actually helping a client who used Adobe's AMS AEM. So Adobe controlled the servers and the AEM software. We just did the development work. Adobe did not upgrade the existing servers either, they spun up new servers for 6.5 and we migrated all the code over (OSGI only).

 

So my advice is to not upgrade, start over.  Hope you can find someone to help.

 

Regards,

View solution in original post

2 Replies

Avatar

Employee Advisor

What are they using ES4 for? Can you please provide the use cases for which ES4 is being used

the reason I am asking is sometimes you don’t need to upgrade, you can just start using latest version of AEM forms depending on the use case 

Avatar

Correct answer by
Level 3

Waldek,

 

I cannot recommend anyone nor do it myself but I can give you some lessons from experience.

I have migrated existing applications, forms, assets, etc. from LiveCycle ES2 to ES3, ES3 to ES4, and AEM 6.4 to 6.5.

One of those migrations was an attempt by an on-premises server and admin team to upgrade. It was a disaster. We ended up spinning up new servers, loading the next version of LiveCycle and moving existing applications and assets from the older version using LCA's (we just did work on the JEE side at that time).

The 6.4 to 6.5 migration was actually helping a client who used Adobe's AMS AEM. So Adobe controlled the servers and the AEM software. We just did the development work. Adobe did not upgrade the existing servers either, they spun up new servers for 6.5 and we migrated all the code over (OSGI only).

 

So my advice is to not upgrade, start over.  Hope you can find someone to help.

 

Regards,