Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Uber jar does not transfer after generating AEM project

Avatar

Level 1

Hello,

I'm not sure if this is the correct forum for this.  I am new to AEM and have been working through some tutorials.  I generated a java project using the adobe archititype and when I try to build I keep getting errors when downloading the uber-jar-6.5.8-apis.jar.  I cannot use the public repository due to proxy issues.  The jar does exist in our Maven repository.

 

I tried to run the mvn clean install in offline mode and I still get the error

Any thoughts on how to resolve this would be appreciated.  I did search the knowledge base but nothing really matched.

 

[ERROR] Failed to execute goal on project learn.core: Could not resolve dependencies for project com.adobe.aem.guides:learn.core:jar:0.0.1-SNAPSHOT: The following artifacts could not be resolved: com.adobe.aem:uber-jar:jar:apis:6.5.8, org.apache.commons:commons-imaging:jar:1.0-R1534292: Could not transfer artifact com.adobe.aem:uber-jar:jar:apis:6.5.8 from/to devops-ally-repo-group (https://nexus.int.ally.com/nexus/repository/ally-repo-group/😞 Transfer failed for https://nexus.int.ally.com/nexus/repository/ally-repo-group/com/adobe/aem/uber-jar/6.5.8/uber-jar-6....: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project learn.core: Could not resolve dependencies for project com.adobe.aem.guides:learn.core:jar:0.0.1-SNAPSHOT: The following artifacts could not be resolved: com.adobe.aem:uber-jar:jar:apis:6.5.8, org.apache.commons:commons-imaging:jar:1.0-R1534292: Could not transfer artifact com.adobe.aem:uber-jar:jar:apis:6.5.8 from/to devops-ally-repo-group (https://nexus.int.ally.com/nexus/repository/ally-repo-group/😞 Transfer failed for https://nexus.int.ally.com/nexus/repository/ally-repo-group/com/adobe/aem/uber-jar/6.5.8/uber-jar-6....

5 Replies

Avatar

Employee Advisor

@gdeacon0720 It seem to be routed via your org repo and they might have certs in place before you are authorized.

 

Get the certs from your team and add them to the JRE.

Avatar

Level 1

Thank you for the quick response.  I don't know what certs to get and when I use our own AEM projects all builds fine.  So I added a second profile in my settings.xml per one of the many articles here and set to be the active one.

My new adobe profile...

<profile>
<id>adobe-public</id>
<activation>
<activeByDefault>true</activeByDefault>
</activation>
<properties>
<releaseRepository-Id>adobe-public-releases</releaseRepository-Id>
<releaseRepository-Name>Adobe Public Releases</releaseRepository-Name>
<releaseRepository-URL>https://repo.maven.apache.org/maven2</releaseRepository-URL>
</properties>
<repositories>
<repository>
<id>adobe-public-releases</id>
<name>Adobe Public Repository</name>
<releases>
<enabled>true</enabled>
<updatePolicy>never</updatePolicy>
</releases>
<snapshots>
<enabled>false</enabled>
</snapshots>
</repository>
</repositories>
<pluginRepositories>
<pluginRepository>
<id>adobe-public-releases</id>
<name>Adobe Public Repository</name>
<releases>
<enabled>true</enabled>
<updatePolicy>never</updatePolicy>
</releases>
<snapshots>
<enabled>false</enabled>
</snapshots>
</pluginRepository>
</pluginRepositories>
</profile>
 
Now it is using the adobe public repo.  However now any downloads not already in my local time out see below
Could not transfer artifact org.apache.commons:commons-imaging:pom:1.0-R1534292 from/to adobe-public-releases (https://repo.adobe.com/nexus/content/groups/public😞 Transfer failed for https://repo.adobe.com/nexus/content/groups/public/org/apache/commons/commons-imaging/1.0-R1534292/c...: Operation timed out (Read failed)
 
I tried the solution from 
 
It mentions adding an adobe cert to my jdk but when I follow the trail to find the cert I hit a page that needs flash which we all know is depricated.
 
Is there a way to get the cert for the adobe public repo?  I even tried to run the maven build this way....
mvn clean install -PautoInstallPackage -Dmaven.wagon.http.ssl.insecure=true -Dmaven.wagon.http.ssl.allowall=true

Same result downloads time out.
 
Thanks again for your hlep
-Garrett

Avatar

Level 1

Thank you for your response.  I appreciate the referenced article however my issue when I use the adobe-public profile shown in my post.  I cannot download the uber.jar-api dependency.  It times out.  If I use our corport Maven repo maven throws a security exception even though the jar is on our repisotry.

 

-Garrett

Avatar

Level 1

So I tried to follow the steps in the referenced article. when I attempt to run mvn eclipse:eclipse the depeency/plugin tree it attempting to install node.js (which I alreay have). why is this.  Anyway it is failing (see below)  Is there a way to stop this or use what is already installed?

 

com.github.eirslett:frontend-maven-plugin:1.7.6:install-node-and-npm (install node and npm) on project learn.ui.frontend: Could not download Node.js: Could not download https://nodejs.org/dist/v10.13.0/node-v10.13.0-darwin-x64.tar.gz: Operation timed out (Read failed) -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal com.github.eirslett:frontend-maven-plugin:1.7.6:install-node-and-npm (install node and npm)

 

Thanks