Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Radio button not showing that it was clicked/selected

islandgirl23
Level 4
Level 4

Hello,

I have two radio buttons in a group (No and Yes) and when I click on one of them, it does not show the black circle in the middle when clicked.  It show it briefly and then disappears.  The other button shows the black circle in the middle when it's clicked.  How can I fix that?  Not sure why it's happening.  

1 Accepted Solution
PulkitJain
Correct answer by
Employee
Employee

@islandgirl23 

This is not the case with OOTB grouped Radio button objects, it works as expected with both PDF and HTML preview. You can test the same with a sample form.

You may have to check if some js applied on an event in the form that could have caused this issue.

View solution in original post

5 Replies
Mayank_Gandhi
Community Advisor
Community Advisor

@islandgirl23 What kind of form is it? HTML or pdf? If HTMl then remove all the scripts, styles and try again.

PulkitJain
Correct answer by
Employee
Employee

@islandgirl23 

This is not the case with OOTB grouped Radio button objects, it works as expected with both PDF and HTML preview. You can test the same with a sample form.

You may have to check if some js applied on an event in the form that could have caused this issue.

View solution in original post

islandgirl23
Level 4
Level 4

Good day,

I found what I think is the problem in my click event of the yes button.  I have the below:

//-
xfa.host.resetData("form1.headersubform.tablesubform.DISPOSITIONLIST.RETURNED");
xfa.host.resetData("form1.headersubform.tablesubform.DISPOSITIONLIST.DESTROYED");
xfa.host.resetData("form1.headersubform.tablesubform.DISPOSITIONLIST.BEINGHELDBY");
xfa.host.resetData("form1.headersubform.tablesubform.DISPOSITIONLIST.other");
xfa.host.resetData("form1.headersubform.tablesubform.DISPOSITIONLIST.OTHERREASON");

 

I'm trying to reset the information in these areas of the my form when the button is clicked.  Am I missing brackets or something?  

 

Mayank_Gandhi
Community Advisor
Community Advisor

@islandgirl23  You can do multiple reset using comma.

xfa.host.resetData("xfa.form.form1.TextField1,xfa.form.form1.TextField2");

 Check for the field expression that could be the issue. You can do ctrl+shift to get absolute som-expression