Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

nosamplecontent (production ready mode) AEM on JBoss

GPhillips58
Level 3
Level 3

How is production ready mode (-r nosamplecontent) implemented in a JBoss installation?  The example given (java -jar aem-quickstart.jar -r nosamplecontent) doesn't apply to JBoss and domain.bat -r nosamplecontent doesn't work.

1 Accepted Solution
SameerDhawan
Correct answer by
Level 3
Level 3

Hi Philips,

Multiple runmode like publish, author, nosamplescontent are supported OOTB in JEE installation. ‘nosamplecontent’ can be configured through LCM while configuring CRX.  You need to uncheck "Install AEM Samples" checkbox for the same.

 

Alternately you may modify the web.xml of cq-author ear and update the runmodes section. Then deploy this modified ear. But the modified  EAR will be wiped off when patching the environment in the future.

So the best option is to uncheck "Install AEM Samples" checkbox while configuring CRX through LCM.

 

Regards

Sameer Dhawan

View solution in original post

4 Replies
SameerDhawan
Correct answer by
Level 3
Level 3

Hi Philips,

Multiple runmode like publish, author, nosamplescontent are supported OOTB in JEE installation. ‘nosamplecontent’ can be configured through LCM while configuring CRX.  You need to uncheck "Install AEM Samples" checkbox for the same.

 

Alternately you may modify the web.xml of cq-author ear and update the runmodes section. Then deploy this modified ear. But the modified  EAR will be wiped off when patching the environment in the future.

So the best option is to uncheck "Install AEM Samples" checkbox while configuring CRX through LCM.

 

Regards

Sameer Dhawan

View solution in original post

GPhillips58
Level 3
Level 3
We did leave "Install AEM Samples" unchecked but We.Retail was still deployed.
SameerDhawan
Level 3
Level 3

Hi @GPhillips58,

 

I believe you unchecked Install "AEM Samples" when the first time you did the installation and ran configuration Manager. 

Please confirm.

 

Regards

Sameer Dhawan