Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events

Maven project using aemfd-client-sdk 6.0.718 (Jun 2022) failed with adobe-aemds-pkg-parent dependencies not found error

Avatar

Level 2

We use aemfd-client-sdk in our organization's Maven codebase for implementing a few in-house AEM Forms extensions.  After upgrading to aemfd-client-sdk 6.0.718 (Jun 2022 release), the Maven codebase no longer builds because of the missing adobe-aemds-pkg-parent 6.0.718 dependency.  It seems the parent dependency of aemfd-client-sdk  was added only in 6.0.718.  Where to download adobe-aemds-pkg-parent 6.0.718 pom.xml?

5 Replies

Avatar

Employee Advisor

@LYUAN 

FYI - All AEM artifacts are now available via Maven Central[0] and the adobe-public profile is not needed so you may have to update the repository URL.

More information here[0]

 

[0] - https://experienceleague.adobe.com/docs/experience-manager-learn/foundation/development/set-up-a-loc... 

 

Avatar

Level 2

@Pulkit_Jain_, yes we are using Maven Central instead of Adobe Public and adobe-aemds-pkg-parent 6.0.718 is not available.  It's referred as the parent  project  for https://repo1.maven.org/maven2/com/adobe/aemfd/aemfd-client-sdk/6.0.718/aemfd-client-sdk-6.0.718.pom.

Avatar

Employee

@LYUAN , the issue has been identified and is being worked on by Adobe. It will be updated in sometime.

Avatar

Employee

@LYUAN 

A new version of the AEM Forms client SDK has been released. Please use the same.