Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Internal Server Error Cannot serve request to /content/xfaforms/profiles/default.html in /libs/xfaforms/render/GET.jsp

ajaydulam
Level 2
Level 2

Hi,

I am using Mac machine and hence installed forms package for Mac. We are trying to test forms with  OOTB template "Basic with Adobe Sign" with all default configurations, Form Model: None,Document of Record Template Configuration: Generate DOR. 

AEM Version : 6.5.7, AEM Forms Package: adobe-aemfd-osx-pkg-6.0.234.zip

 

- When i try to go to step2 : verify step, it gives below error:

Internal Server Error

Cannot serve request to /content/xfaforms/profiles/default.html in /libs/xfaforms/render/GET.jsp

Exception:

com.adobe.forms.service.LCFormsServiceException
	at com.adobe.forms.service.impl.LCFormsOsgiServiceImpl.render(LCFormsOsgiServiceImpl.scala:92)
	at com.adobe.forms.service.impl.LCFormsServiceImpl.render(LCFormsServiceImpl.java:126)
	at org.apache.jsp.libs.xfaforms.render.GET_jsp._jspService(GET_jsp.java:115)

 

Not sure, if am missing some thing, but wanted help on checking whats the issue and debugging and fixing the issue.

 

 

AEM 6.5.7 AEM Adaptive Forms
1 Accepted Solution
Kosta_Prokopiu1
Correct answer by
Employee
Employee

AEM itself may work on Mac as it runs in Java. AEM Forms on the other hand has native components (XMLForms.exe for example) and Mac OS is not supported for those.

View solution in original post

6 Replies
Kosta_Prokopiu1
Correct answer by
Employee
Employee

AEM itself may work on Mac as it runs in Java. AEM Forms on the other hand has native components (XMLForms.exe for example) and Mac OS is not supported for those.

View solution in original post

ajaydulam
Level 2
Level 2
Thank you Kosta, but what am doing is basic forms with sign functionality. If AEM Forms Is not supported on Mac OS, then package shouldn't be there ideally right. Also I have seen this errror on linux server as well.
Kosta_Prokopiu1
Employee
Employee
I see that the OSX package is for demo only but not supported as a runtime or prod environment. Since OSX is similar to Linux you may be missing some runtime libraries that are required.
ajaydulam
Level 2
Level 2
Kosta, I will try it on azure linux machine, wanted to confirm with you, if installing "adobe-aemfd-linux-pkg-6.0.234.zip" package on top of AEM6.5.7 works or there are limitations here too?