Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

dispatcher configuration in apache

aem_dev1
Level 3
Level 3

Hi, i have installed AEM 6 in tomcat server (Unix). Publish port is 4503 and application will be accessed as below.

Example content: localhost:4503/aempublish/content/geometrixx-media/en.html.

Installed SSL in tomcat and apache web server. i am using dispatcher 4.1.8 and added below configs

/virtualhosts
      {
        "localhost:10000"
      }

    /renders
      {
      /rend01
        {

        /hostname "127.0.0.1"
        /port "4503"

      }
in filters added below.
/0023 { /type "allow" /url "/aempublish/content/*


Apache configurations: Apache is running at 4504
<VirtualHost localhost:4504>
        ProxyRequests Off
        <Location "/" >
                ProxyPass  https://localhost:10000/ (tried http as well)
                ProxyPassReverse  https://localhost:10000/ (tried http as well)
        </Location>
        SSLEngine on
        SSLCertificateFile <cert file location>
        SSLCertificateKeyFile <cert key location>
</VirtualHost>


<VirtualHost localhost:10000>
        ProxyPreserveHost On
        <Directory "/" >
          <IfModule disp_apache2.c>
                  SetHandler dispatcher-handler
                  ModMimeUsePathInfo On
          </IfModule>
        </Directory>
       SSLEngine on
        SSLCertificateFile <cert file location>
        SSLCertificateKeyFile <cert key location>

</VirtualHost>

 

When i hit the page with apache port i am getting 503 service temporarily unavailable and also see below in apache error logs. But no error in dispatcher logs

[Wed Apr 01 11:38:49 2015] [error] (111)Connection refused: proxy: HTTPS: attempt to connect to <ip address>:10000 (localhost) failed
[Wed Apr 01 11:38:49 2015] [error] ap_proxy_connect_backend disabling worker for (localhost)
[Wed Apr 01 11:38:49 2015] [error] proxy: HTTPS: disabled connection for (localhost)
[Wed Apr 01 11:38:53 2015] [error] proxy: HTTPS: disabled connection for (localhost)
[Wed Apr 01 11:38:53 2015] [error] proxy: HTTPS: disabled connection for (localhost)

when i tried with http, got the same error but it says http: disabled connection for (localhost)

Appreciated for quick response

1 Accepted Solution
mandeepg6805152
Correct answer by
Employee
Employee

Let me ask a few basic questions first. Are you able to access you page when you hit the apache port ?

If you are not using dispacher but trying a web server (apache in your case). This looks to me a very common configuration problem. 

Can you try the first few links mentioned in  https://www.google.co.in/search?q=ap_proxy_connect_backend+disabling+worker+for&oq=ap_proxy_connect_...

 

Let me know if you still face the issue. I would  then try to setup the same architecture and see what is going wrong.

View solution in original post

0 Replies
mandeepg6805152
Correct answer by
Employee
Employee

Let me ask a few basic questions first. Are you able to access you page when you hit the apache port ?

If you are not using dispacher but trying a web server (apache in your case). This looks to me a very common configuration problem. 

Can you try the first few links mentioned in  https://www.google.co.in/search?q=ap_proxy_connect_backend+disabling+worker+for&oq=ap_proxy_connect_...

 

Let me know if you still face the issue. I would  then try to setup the same architecture and see what is going wrong.

View solution in original post