Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Cross browser account activation - throws 404 Error

Avatar

Level 2

Problem Statement: We are using AEM out-of-the-box Adaptive forms for our application. Here when a new user tries to register to the portal, a code will be sent to the end user's webmail id for activation and further clicking upon the link will redirect them to the pre-registration page. This functionality is working fine when they access their webmail on the same browser, Wherein it throws 404 on cross-browser( different browser/mobile/devices) account activation.


Root Cause Analysis:

Below are the current scenarios that we are seeing:

1. Account creation and activation on the same browser on Laptop / Desktop – Successful.
2. Account creation in 1 browser and activation in different browser on Laptop / Desktop – Unsuccessful (throws 404 )
3. Account creation in 1 browser and activation in different browser on Mobile – Unsuccessful ( throws 404 )
4. Account creation on Laptop and activation on Mobile – Unsuccessful (throws 404 )
5. Account creation on mobile (Chrome Incognito mode) and account activation on Mobile Chrome normal browser – Unsuccessful


Upon further investigation we have found some issues related to Cookies that are part of the request headers which are containing the information regarding the CLIENT_ID.
For a successful request the cookie contains all the information our Application is looking for, and for unsuccessful request the cookie is empty.


Below is an error showing on our end for all unsuccessful cases :
21.09.2022 11:19:00.813 *ERROR* [qtp1202784026-2137] com.adobe.granite.auth.oauth.impl.OAuthAuthenticationHandler extractCredentials: Failed to retrieve user identification; cannot authenticate

Expectations-
Successful landing on pre-registration page while activating the account from any browser/device. Let us know if there is any code fix available for this issue. If not please raise a ticket and let us know when can we get a fix for this issue.

 

3 Replies

Avatar

Employee Advisor

@BhaskarDandu Hi can you give more details on this implementation?

 

"Here when a new user tries to register to the portal, a code will be sent to the end user's webmail id for activation and further clicking upon the link will redirect them to the pre-registration page. "

Avatar

Level 2

@Mayank_Gandhi Hi , Good day !

"Here when a new user tries to register to the portal, a code will be sent to the end user's webmail id for activation and further clicking upon the link will redirect them to the pre-registration page. "

Yes, this is how we follow the registration process.

When the end user uses the same browser for mail registration & activation after that it will redirect them to our AEM landing page( pre-registration page). And the user clicking link in different browser or different device it will throws 404 error.

Please let us know if you want us to share/add more inputs on this request. Also please raise ticket for this issue.