Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

[AF] [AEM-AF-901-004]: Encountered an internal error while submitting the form

dilips50359074
Level 3
Level 3

CustomSubmit_Action.pngCustomSubmit_Action.png

 

Hi AEM Adaptive form Guru's

Highlighted in red is where I am getting error when browser from dispatcher

 

Note: I have checked similar questions in AEM forums and it is not helping resolve the issue.

 

Environment : AEM 6.5 

Author | Publish | Dispatcher  environment

Adaptive form works in Author | Adaptive form works in publish | Error when click on submit in AF when I use hostname (from Dispatcher)

[AF] [AEM-AF-901-004]: Encountered an internal error while submitting the form

 

Accessing adaptive form from Dispatcher using the hostname does not work.  When I click on submit in the AF form  I get the following error.  I have just used on textbox and one submit button in AF(Adaptive form) 

 

When I check the Network/Console of the browser I see the following errors

Post http:/sdfjlsjflsjdlfsfd.com/content/forms/af/wtc/testing/jcr:content/guideContainer.af.internalsubmi... 404 (Not Found)

I have commented whole of dispatcher filter file and allowed everything, still I get the internal error.

Did anyone face this issue.  

Let me know if you need any additional information.

 

Regards

Dilip

1 Accepted Solution
workflowuser
Correct answer by
Employee
Employee

workflowuser_0-1597245584283.png

That is my settings for Apache Sling Referrer Filter

suggest you log a support ticket to get this resolved. 

 

View solution in original post

35 Replies
mrStash
Level 1
Level 1
Any resolution on this issue, having the same problem, AEM 6.5
dilips50359074
Level 3
Level 3
<% %><%@include file="/libs/foundation/global.jsp"%> <%@taglib prefix="cq" uri="http://www.day.com/taglibs/cq/1.0"%> <%@ page import="org.apache.sling.api.request.RequestParameter,com.day.cq.wcm.api.WCMMode,com.adobe.forms.common.submitutils.CustomParameterRequest,com.adobe.aemds.guide.submitutils.*" %> <%@ page import="org.apache.sling.api.request.RequestParameter,com.day.cq.wcm.api.WCMMode" %> <%@page session="false" %> <% com.adobe.aemds.guide.utils.GuideSubmitUtils.setForwardPath(slingRequest,"/bin/storeafsubmission",null,null); %>
dilips50359074
Level 3
Level 3
I have put that in post.POST.jsp under Apps in Sling:folder
dilips50359074
Level 3
Level 3
I am not sure if it is hitting this from the internalSubmit.jsp as this jsp is not found
workflowuser
Employee
Employee
to confirm this works for you without going through the dispatcher - is that correct
workflowuser
Employee
Employee
my dispatcher.ini file has /0924 { /type "allow" /method "POST" /url "/bin/batchServlet*" } /0925 { /type "allow" /method "GET" /url "/bin/applyrights*" }
dilips50359074
Level 3
Level 3
i have allowed all the paths /0001 { /type "allow" method "*" /url "*" } /0002 { /type "allow" method "*" /path "*"}
dilips50359074
Level 3
Level 3
can you paste here the exact forms package you used.... try and match that
workflowuser
Employee
Employee

Can you provide the screen shot of your form submission configuration?

also can you check your dispatcher logs?

dilips50359074
Level 3
Level 3

grep -i "interal" dispatcher.log

[Sun Aug 09 21:32:09 2020] [I] [pid 23745] "POST /content/forms/af/wtc/contact-us/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 8ms [publishfarm/-] [Sun Aug 09 21:32:12 2020] [I] [pid 23745] "POST /content/forms/af/wtc/contact-us/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 8ms [publishfarm/-] [Sun Aug 09 21:40:33 2020] [I] [pid 23509] "POST /content/forms/af/wtc/basicform/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 7ms [publishfarm/-] [Sun Aug 09 21:40:37 2020] [I] [pid 23509] "POST /content/forms/af/wtc/basicform/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 7ms [publishfarm/-] [Sun Aug 09 21:40:41 2020] [I] [pid 23509] "POST /content/forms/af/wtc/basicform/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 8ms [publishfarm/-] [Sun Aug 09 22:44:26 2020] [I] [pid 118904] "GET /etc.clientlibs/wtc/clientlibs/resources/icons/svg/InternalIcon_Black.svg" - - 0ms [publishfarm/-] [Sun Aug 09 22:44:26 2020] [I] [pid 23647] "GET /etc.clientlibs/wtc/clientlibs/resources/icons/svg/InternalIcon_White.svg" - - 1ms [publishfarm/-] [Sun Aug 09 22:44:35 2020] [I] [pid 23742] "POST /content/forms/af/wtc/contact-us/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 8ms [publishfarm/-] [Sun Aug 09 22:44:48 2020] [I] [pid 23647] "POST /content/forms/af/wtc/contact-us/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 8ms [publishfarm/-] [Mon Aug 10 00:30:32 2020] [I] [pid 15214] "GET /etc.clientlibs/wtc/clientlibs/resources/icons/svg/InternalIcon_Black.svg" - - 0ms [publishfarm/-] [Mon Aug 10 00:30:32 2020] [I] [pid 15214] "GET /etc.clientlibs/wtc/clientlibs/resources/icons/svg/InternalIcon_White.svg" - - 0ms [publishfarm/-] [Mon Aug 10 00:30:49 2020] [I] [pid 15593] "POST /content/forms/af/wtc/contact-us/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 9ms [publishfarm/-] [Mon Aug 10 00:48:55 2020] [I] [pid 118904] "POST /content/forms/af/wtc/testing/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 9ms [publishfarm/-] [Mon Aug 10 00:49:23 2020] [I] [pid 15214] "POST /content/forms/af/wtc/testing/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 7ms [publishfarm/-] [Mon Aug 10 00:49:39 2020] [I] [pid 10255] "POST /content/forms/af/wtc/testing/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 8ms [publishfarm/-] [Mon Aug 10 02:08:20 2020] [I] [pid 23750] "POST /content/forms/af/wtc/testing/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 11ms [publishfarm/-] [Mon Aug 10 02:32:59 2020] [I] [pid 31733] "POST /content/forms/af/wtc/testing/jcr:content/guideContainer.af.internalsubmit.jsp" ! - 8ms [publishfarm/-]

workflowuser
Employee
Employee

can you put a simple System.out.println statement in your jsp and see if that is being written to AEM server log

dilips50359074
Level 3
Level 3
I do not think the dispatcher request is coming till jsp as per the console error it is stopping at internalSubmit.jsp