Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.5 formservice Throwing java.lang.nosuchmethoderror

kalyan
Level 2
Level 2

We are attempting to connect to AEM 6.5 from a legacy system that was connected to AEM6.4. After updating the AEM to 6.5 and upgrading the proxy jars we are getting the following error when we try to call the Formservice over SOAP.

 

Error calling:

formsService.renderPDFForm(templatePath, inputBLOB, pdfFormRenderSpec, uriValues, null,

                                                            outRenderPDFFormResultDoc, longHolder, stringHolder, formsResult);

 

Error:

Caused by: java.lang.NoSuchMethodFoundError: com.adobe.idp.services.forms.FormsService.renderPDFForm(Ljava/lang/String;Lcom/adobe/idp/services/forms/BLOB;Lcom/adobe/idp/services/forms/PDFFormRenderSpec;Lcom/adobe/idp/services/forms/URLSpec;Lorg/apache/xml/xml_soap/Map;Ljavax/xml/ws/Holder;Ljavax/xml/ws/Holder;Ljavax/xml/ws/Holder;Ljavax/xml/ws/Holder;)V

    

We are running on WebLogic 10.3.6 using java 1.7 and AEM 6.5 is on jboss 7.1.4.GA -redHat

 

Thanks

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

6.5
1 Accepted Solution
kalyan
Correct answer by
Level 2
Level 2

The issue was with the proxy creation. The adobe documentation are not accurate. When you create the proxies using WS Import the packages got created correctly and resolved the issue.Thanks all for checking.

View solution in original post

6 Replies
Kosta_Prokopiu1
Employee
Employee

Hi,

I assume this is AEM Forms JEE 6.5 and you have rebuilt your WL application with the latest adobe client jars and whatever else is given in the SDK section of the 6.5 installation.

The first thing I am not sure about is if Java 1.7 will still work with this, AEM Forms runs under Java 8 or 11 and all jars are compiled for 1.8 and 11.

But what puzzles me is your formsService API call. The 6.4 Javadoc shows the following interface:

https://helpx.adobe.com/experience-manager/6-4/forms/ProgramLC/javadoc/com/adobe/livecycle/formsserv...

kprokopi_0-1596728149281.png

Your API call contains much more parameters not documented. The error we see in your post looks consistent if I have not misinterpreted your information.

 

kalyan
Level 2
Level 2
Moved the query to the requested forum
kalyan
Correct answer by
Level 2
Level 2

The issue was with the proxy creation. The adobe documentation are not accurate. When you create the proxies using WS Import the packages got created correctly and resolved the issue.Thanks all for checking.

View solution in original post