AEM 6.3 - Cannot read property 'WCM' of undefined

Avatar

Avatar
Validate 1
Level 2
fabioper85
Level 2

Likes

5 likes

Total Posts

33 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 2
fabioper85
Level 2

Likes

5 likes

Total Posts

33 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
fabioper85
Level 2

17-09-2018

Hi everyone

Today I found this problem that I've never seen : "Cannot read property 'WCM' of undefined"

WCM.PNG

Inspecting the code I found this error on widget.js

sidekick.PNG

Actually, I can't edit at all on my forms...no way!

Can someone help me?

Thanks

Fabio

Replies

Avatar

Avatar
Springboard
Level 10
Mayank_Gandhi
Level 10

Likes

328 likes

Total Posts

1,153 posts

Correct reply

185 solutions
Top badges earned
Springboard
Establish
Validate 1
Contributor 2
Ignite 5
View profile

Avatar
Springboard
Level 10
Mayank_Gandhi
Level 10

Likes

328 likes

Total Posts

1,153 posts

Correct reply

185 solutions
Top badges earned
Springboard
Establish
Validate 1
Contributor 2
Ignite 5
View profile
Mayank_Gandhi
Level 10

17-09-2018

Can you check if it's happening across all the browsers? Please clear the Browser cache and try creating a new form as well.

Avatar

Avatar
Validate 1
Level 2
fabioper85
Level 2

Likes

5 likes

Total Posts

33 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 2
fabioper85
Level 2

Likes

5 likes

Total Posts

33 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
fabioper85
Level 2

18-09-2018

I checked

Doesn't work in any new form...and all across browsers!

Really strange...

It's about libs or something like this?

Thank you so much, Mayank Gandhi

Fabio

Avatar

Avatar
Validate 1
Level 2
fabioper85
Level 2

Likes

5 likes

Total Posts

33 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 2
fabioper85
Level 2

Likes

5 likes

Total Posts

33 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
fabioper85
Level 2

18-09-2018

guidelibNotDefined.PNG

This is the log in PREVIEW MODE

I really don't know why this happens...

Fabio

Avatar

Avatar
Springboard
Level 10
Mayank_Gandhi
Level 10

Likes

328 likes

Total Posts

1,153 posts

Correct reply

185 solutions
Top badges earned
Springboard
Establish
Validate 1
Contributor 2
Ignite 5
View profile

Avatar
Springboard
Level 10
Mayank_Gandhi
Level 10

Likes

328 likes

Total Posts

1,153 posts

Correct reply

185 solutions
Top badges earned
Springboard
Establish
Validate 1
Contributor 2
Ignite 5
View profile
Mayank_Gandhi
Level 10

18-09-2018

Fabio,

Can you remove or disable all the plugins you have in Chrome and try again.

Thanks,

Mayank

Avatar

Avatar
Give Back
Level 1
shahidwaris
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile

Avatar
Give Back
Level 1
shahidwaris
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
shahidwaris
Level 1

17-06-2020

@Arun_Patidar please help in resolving this issue as I am facing the same issue but here I couldn't find any solutions.

 

Thanks,

Shahid

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,462 likes

Total Posts

3,329 posts

Correct reply

949 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,462 likes

Total Posts

3,329 posts

Correct reply

949 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

17-06-2020

Hi, I am not sure if I am the right person to assist you here for AEM Forms related query? I would suggest you can wait for other's reply and try in vanilla instance and if you see same issue, you can open a support ticket for Adobe to look into this.