Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.3.0.2 - Forms Installation

James_R_Green
Level 7
Level 7

Hi,

Our systems currently have aem-6.3.0-cfp-2.0.zip installed.

Making the system version 6.3.0.2

We need to roll forms out to this system.

To do this, I would normally install AEM-FORMS-6.3.2.2-<OS>-4.1.74

The pre-requisites for this package are:

aem-service-pkg-6.3.2.zip

and

aem-6.3.2-cfp-2.0.zip

This works on my local system. Now that I am looking to roll this out to production I have checked the release notes for 6.3 SP2 it suggests installing 6.3.3 instead:

AEM 6.3.2.0 Release Notes

Adobe Experience Manager 6.3.3.0, released on September 12, 2018, is the latest Service Pack (SP) for AEM 6.3 that includes all AEM 6.3 Service Packs and Cumulative Fix Packs till date.

For all updates on AEM 6.3 versions, it is recommended to install the latest Service Pack 6.3.3.0.

So, I tried installing the following on our 6.3.0.2 system:

  • AEM-6.3.3.0-6.3.3
  • AEM-CFP-6.3.3.1-1.0
  • AEM-FORMS-6.3.3.1-<OS>-4.1.90

This appears to be ok , until I look at the menu under sites in the touchui  (example.com/sites.html) it shows an error half way down the menu:

error-touch-ui.jpg

On a fresh install installing these 3 packages works fine. I did this to validate my process is correct - I wait for the logs to stop and restart between packages.

So, then then I tried to uninstall aem-6.3.0-cfp-2.0.zip before installing the 3 packages, this gives an error:

Error: This item [/etc/packages/day/cq60/product/.snapshot/cq-content-6.3.66.zip] does not exist anymore

Questions:

Should I be able to install Forms 6.3.3 on top of 6.3.0.2? If so, what is the process?

If not - should we just install AEM forms 6.3.2?

       

1 Accepted Solution
WASIL
Correct answer by
Employee
Employee

Hi Jim - Indeed the same Wasil . Please log a DayCare ticket, I'll look into this further.

Cheers,

Wasil

View solution in original post

9 Replies
Mayank_Gandhi
Community Advisor
Community Advisor

Hi James,

Uninstalling of CFP or SP is not supported. The basic convention of any form package is that it's equivalent AEM package should exist on the system. Let's take an example here

1. Applying an SP

A fresh AEM instance with base forms package-> apply AEM 6.3.3 -> apply forms 6.3.3.

2. For CFP you need SP beforehand. So order becomes

A fresh AEM instance with base forms package-> apply 6.3.3 -> apply AEM 6.3.3.1 -> Apply Forms 6.3.3.1

In case you mess up with the package install, just roll back the CRX and start over. Thus it's very important to backup your CRX and then apply the patches.

Thanks,

Mayank

James_R_Green
Level 7
Level 7

Hi Mayank,

Thabks for the reply.

The instances of AEM in question already have aem-6.3.0-cfp-2.0.zip (not a fresh install as described in option 1 and 2 in your reply). What should I do in that case to install forms?

Thanks,

James

Mayank_Gandhi
Community Advisor
Community Advisor

Please apply patches in the order as suggested in option 2.

Start with 6.3.0.2, apply 6.3.3 -> apply AEM 6.3.3.1 -> Apply Forms 6.3.3.1

Thanks,

Mayank

James_R_Green
Level 7
Level 7

Hi Mayank,

I may be missing something. But isn't that what I tried and got an error from the ui in my original post? Here:

So, I tried installing the following on our 6.3.0.2 system:

  • AEM-6.3.3.0-6.3.3
  • AEM-CFP-6.3.3.1-1.0
  • AEM-FORMS-6.3.3.1-<OS>-4.1.90

This appears to be ok , until I look at the menu under sites in the touchui  (example.com/sites.html) it shows an error half way down the menu:

Refer to screenshot in original post

The error makes the touch ui unusable. Can you try this yourself to see if you get the same error? Or suggest how my approach is different to what you are saying in option 2 

WASIL
Employee
Employee

Hi Jim, It might be something with the changed code upon application of SP/CFP. You could try after recompiling JSPs/clientlibs[1].

Cheers,

Wasil

[1] How to force a recompilation of all Sling scripts jsps, java, and sightly in AEM 6.4

James_R_Green
Level 7
Level 7

HiWASIL​​

That would have been great, but unfortunately that didn't work. (recompiled JSPs and clientlibs)

As we are working on the same project (I guess you are the same Wasil ) can I ask you to look into this one for me? It is the highest priority item at the moment.

Do you need a day care ticket?

Thanks,

Jim

WASIL
Correct answer by
Employee
Employee

Hi Jim - Indeed the same Wasil . Please log a DayCare ticket, I'll look into this further.

Cheers,

Wasil

View solution in original post

James_R_Green
Level 7
Level 7

Great - thanks Wasil.

We can share the details on here once we know the answer in case others encounter this problem

James_R_Green
Level 7
Level 7

Closing this issue as it appears to be due to other packages on our instance of aem.

We will continue to investigate this via the day care ticket.