Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Asset Always showing Modified during "Import from AEM Server " in Visual Code Studio

Avatar

Level 3

Hi All,

 

I have created a AEM project using AEM-Archetype 32. 

 

I am using Visual Code Studio for development. Assume my /content/dam folder contains some digital assets and I am going to add one new image to my dam folder.

 

After uploading I used "Import from AEM Server" Option in Visual Studio Code for downloading it in my local environment. Then when i try to commit it to my AEM Cloud Git Status it showing all the images are modified instead of showing only the last image I added.

 

Any idea why its showing all the assets are modified during Git status ?

 

Cheers 🙂

1 Accepted Solution

Avatar

Correct answer by
Level 3

@SkyGazer try to update filter.xml available at ui.content/src/main/content/META-INF/vault/filter.xml path with mode='merge' and  see it it works. 

ie:  <filter root="/content/dam/banner" mode="merge"/>

View solution in original post

3 Replies

Avatar

Level 3

@SkyGazer  at first place it seems that you are importing parent /content/dam folder from remote server and due to that all the assets are getting imported again in your local, which might be updating modified date of imported assets. work around to solve this problem is selective commit, instead of committing complete content/dam, just commit added/modified asset only.

 

Avatar

Level 3

Hi @NitinL ,

 

Those assets are showing modified whenever I tried to import from AEM Server.

 

Assume we have folder named "banner" and inside that we have around 10 assets and we are adding one more asset to the banner folder. And when I tried to do import the asset by selecting the folder from visual studio , I am not getting why its showed modified all the times whenever I tried commit to server all the time.

 

 

Cheers 🙂

 

Avatar

Correct answer by
Level 3

@SkyGazer try to update filter.xml available at ui.content/src/main/content/META-INF/vault/filter.xml path with mode='merge' and  see it it works. 

ie:  <filter root="/content/dam/banner" mode="merge"/>