Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!
SOLVED

AEM 6.5 Upgrade | DAM Update Asset is not starting

Avatar

Level 1

Hi All,

We have upgraded our AEM instance from 6.3 to 6.5 and everything went smoothly but the out of box workflow "DAM Update Asset" is not starting at all and throwing the below exception on error.log file. Can you please anyone look into this issue as it final stage of Go Live. 

Exception in error.log

28.07.2021 05:42:09.825 *ERROR* [sling-threadpool-0eb5c720-d171-4df6-bcda-2b17ca67c9f6-(apache-sling-job-thread-pool)-26-Granite Transient Workflow Queue(com/adobe/granite/workflow/transient/job/var/workflow/models/dam/update_asset)] com.adobe.granite.workflow.core.job.JobHandler Error processing workflow job
java.lang.NullPointerException: null
	at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:192)
	at org.apache.jackrabbit.oak.jcr.session.SessionImpl.getNode(SessionImpl.java:304) [org.apache.jackrabbit.oak-jcr:1.22.4]
	at com.adobe.granite.repository.impl.CRX3SessionImpl.getNode(CRX3SessionImpl.java:173) [com.adobe.granite.repository:1.6.28.CQ650-B0001]
	at com.adobe.granite.workflow.core.jcr.WorkflowBucketManager.createWorkflowInstanceNode(WorkflowBucketManager.java:178) [com.adobe.granite.workflow.core:2.0.240.CQ650-B0017]
	at com.adobe.granite.workflow.core.jcr.WorkflowManager.createWorkflowInstance(WorkflowManager.java:324) [com.adobe.granite.workflow.core:2.0.240.CQ650-B0017]
	at com.adobe.granite.workflow.core.job.JobHandler.process(JobHandler.java:159) [com.adobe.granite.workflow.core:2.0.240.CQ650-B0017]
	at org.apache.sling.event.impl.jobs.JobConsumerManager$JobConsumerWrapper.process(JobConsumerManager.java:502) [org.apache.sling.event:4.2.12]
	at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.startJob(JobQueueImpl.java:293) [org.apache.sling.event:4.2.12]
	at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.access$100(JobQueueImpl.java:60) [org.apache.sling.event:4.2.12]
	at org.apache.sling.event.impl.jobs.queues.JobQueueImpl$1.run(JobQueueImpl.java:229) [org.apache.sling.event:4.2.12]
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Workflows are stored differently in AEM 6.5. Can you please make sure all the workflows are available in below paths:

/conf/global/settings/workflow/models

/etc/workflow/models

If not, please create a package from 6.3 instance, upload the package to 6.5, restart the instance once and try running the workflow again. Hope this helps.

 

 

 

View solution in original post

3 Replies

Avatar

Correct answer by
Community Advisor

Workflows are stored differently in AEM 6.5. Can you please make sure all the workflows are available in below paths:

/conf/global/settings/workflow/models

/etc/workflow/models

If not, please create a package from 6.3 instance, upload the package to 6.5, restart the instance once and try running the workflow again. Hope this helps.

 

 

 

Avatar

Level 1
Hi Diksha, I have tried the mentioned steps but still it is not working.

Avatar

Community Advisor
I would recommend opening a daycare ticket, since you have a tight deadline. They should be able to check the instance, logs and identify the exact issue.