SMPP Not Sending - ClickSend

Avatar

Avatar

cwammes

Avatar

cwammes

cwammes

28-11-2020

Hi,

 

I have setup ClickSend as an external account using their guide:

https://help.clicksend.com/article/l6hbrh9y82-send-sms-with-adobe-campaign

 

I've sent them our IP addresses provided by Adobe Support to have them whitelisted.  However, when I try to send an SMS, nothing appears to happen.

 

I've enabled verbose logging, however, when I look at a delivery log, I don't see anything in the log.  Are those logs stored somewhere else?

 

Screen Shot 2020-11-28 at 1.41.39 PM.png

 

Any tips on what I should be looking at to debug this further?

 

Thanks,
Chris

Accepted Solutions (0)

Answers (6)

Answers (6)

Avatar

Avatar

xavierv6303633

Avatar

xavierv6303633

xavierv6303633

30-11-2020

Hi @cwammes ,

 

We had the exact same issue with ClickSend a while back. Is the message you're trying to send bigger than 160 characters by any chance?

 

If so, you need to activate the 'message payload' option in the external account; this seems to be the only way to send multi-part messages with ClickSend through Adobe. This however has a big drawback : delivery receipts can't be sent back correctly to Adobe with this option actived, so any bounces won't be saved in Adobe; the delivery logs will all be set as 'sent' even though some had errors, and the 'billable sms count' will always be 1 sms per person, even if a single sms contains 8 messages (8*160chars).

 

https://helpx.adobe.com/campaign/kb/sms-connector-protocol-and-settings.html  (chapter ‘MULTIPART SMS (LONG SMS)’)

 

We had a nightmare of a time with Adobe Support (more than 1 month and several calls !), where they were refusing to acknlowledge there was something wrong on their side with the way they read the delivery receipts, and ClickSend was saying the problem was with Adobe, so we just ended up switching provider and now everything works fine.

 

Kr,

Xavier

Avatar

Avatar

shelly-goel

MVP

Avatar

shelly-goel

MVP

shelly-goel
MVP

28-11-2020

@cwammes  In case you all the right settings from your end (country code is also included in the number) but sms remains in Pending state, please raise a ticket with Adobe support to validate the environment set up. Please refer: https://experienceleaguecommunities.adobe.com/t5/adobe-campaign-standard/help-can-t-send-sms-message...

This thread also mentions that there are two IPs that needs to be whitelisted.

Avatar

Avatar

cwammes

Avatar

cwammes

cwammes

28-11-2020

Thank you for the replies, I have tried to send another SMS message with the same result.  I have let this one run for about 3 hours, with no additional information appearing in the logs. 

 

Screen Shot 2020-11-28 at 8.46.45 PM.pngScreen Shot 2020-11-28 at 8.47.20 PM.pngScreen Shot 2020-11-28 at 8.47.46 PM.pngScreen Shot 2020-11-28 at 8.47.58 PM.png

Avatar

Avatar

shelly-goel

MVP

Avatar

shelly-goel

MVP

shelly-goel
MVP

28-11-2020

@cwammes  In the logs that you've shared, it shows Send Status as "Stopped" and Canceled by User. Did you stop the delivery/ workflow by any chance? It does show "1 message waiting" before it is stopped. Additionally, check the sending logs (without stopping it) where it will show details of the message being sent.

Avatar

Avatar

DavidKangni

MVP

Avatar

DavidKangni

MVP

DavidKangni
MVP

28-11-2020

Please wait 10-15 min to see if you sending logs are updated.

If you don't have nothing in the logs, you may check you exclusion logs or audit tab to see if the delivery was started without any errors.

Thanks,

David 

Avatar

Avatar

Sukrity_Wadhwa

Employee

Avatar

Sukrity_Wadhwa

Employee

Sukrity_Wadhwa
Employee

03-12-2020

Hi @cwammes,

Was any of the given solutions helpful in resolving this query for you or do you need more help with it? Do let us know.

Thanks!