Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Issue while integrating AEM and Campaign

krishnakanthp76
Level 2
Level 2

Hi,

I have ACM sever and AEM setup in my local machine (That makes both of them in same IP with different ports AEM 4502 and ACM 8080).

I followed following steps to integrate ACM with AEM

  • Added AEM URL and credentials in External accounts
  • Selected aemserver operator and changed the security zone to Private + VPN(or public or only lan).
  • Changed the allowUserPassword value to true in serverConf.xml file.

1473276_pastedImage_7.png

  • Created a new Adobe Campaign service connection.
  • Added credentials and Api endpoint.

Ideally it AEM should be connected to Campaign in this step. But I'm getting the following message.

1473275_pastedImage_2.png

Am I missing anything specific? Can anyone please help me with this issue?

Also, in monitoring universe, I see mta process missing. Does this has anything to do with this integration? (Refer Screenshot below)

1473277_pastedImage_8.png

Thanks

Krishna

1 Accepted Solution
Vapsy
Correct answer by
Employee
Employee

You can check the Campaign SSL logs or logins.log to identify what IP is being captured by Campaign.

this is what I've done on my local instance

Inside the config-<instance_name>.xml whitelisted localhost

1474731_pastedImage_0.png

Hope this helps.

Regards,
Vipul

View solution in original post

7 Replies
krishnakanthp76
Level 2
Level 2

Any One?

Vipul Raghav

florentlb

Please let me know what I'm missing here.

Thanks,

Krishna

Vapsy
Employee
Employee

Hi Krishna,

Did you change the password of aemserver operator inside Campaign?

If not, please change it and save. Then use the correct password in AEM.

Then you need to whitelist AEM IP inside the LAN securityZone. If it is localhost then also whitelist that IP.

Regards,
Vipul

krishnakanthp76
Level 2
Level 2

Hi Vipul ,

I have changed the password but unable to login. I'm Unclear about this localhost IP Whitelist part. Where i can find any documentation on why and how we need to whitelist even if both the instances are in same domain but on different port? Or if you have any idea, please can you explain?

(or)

Is this something I need to contact my network team?

Vapsy
Correct answer by
Employee
Employee

You can check the Campaign SSL logs or logins.log to identify what IP is being captured by Campaign.

this is what I've done on my local instance

Inside the config-<instance_name>.xml whitelisted localhost

1474731_pastedImage_0.png

Hope this helps.

Regards,
Vipul

View solution in original post

krishnakanthp76
Level 2
Level 2

Thank you so much Vipul , I was able to integrate both the environments(At least partially). Wish we had a detailed documentation and troubleshooting steps for AEM and AC integration. Anyway Thank you once again.