How to add SMTP- List unsubscribe

CIGM

18-10-2017

Hi there,

I am trying to add the SMTP to the header of my emails following the following instructions here: Technical recommendations

However, I can;t make it work. I have built the link by adding the URL unsubscribe email address on the webappp and the ide recipient Crypt link. It looks as below:

1326968_pastedImage_2.png

Could you advise please?

Thanks,

C

Accepted Solutions (1)

Accepted Solutions (1)

CIGM

31-10-2017

Hi Florent,

Although it did not work, I don't think David's suggestion was wrong as it was working for him. I just pasted my unsubscribed link and send an email with some HTML content on (I was just sending a lorem ipsum email). It then worked.

Thanks for your help and patience.

cc

Answers (12)

Answers (12)

CIGM

18-10-2017

Thank you Florent. I have tried with your suggestion but still is not working... the email is being sent but the unsubs link does not display on the email interface.

Any thoughts what could that be?

1327163_pastedImage_0.png

I have also tried to do it with the Adobe SMTP by default - see below but is not working either.

1327164_pastedImage_1.png

Best,

C

Majid_Awan

07-08-2018

Hi Florent,

I hope you are well.

I am experiencing a similar issue where I am implementing the List Unsubscribe setup in my deliveries. I have used the code you supplied:

<% if ((recipient.domain == 'gmail.com')|| (recipient.domain == 'gmail.co.uk')){%> Precedence: bulk <%}%>

List-Unsubscribe: <mailto:<%@ include option='NmsEmail_DefaultErrorAddr' %>?subject=unsubscribe<%= escape(message.mimeMessageId) %>>

This code is working in the Gmail but not in hotmail/ outlook. I have even tried stripping off the if statement and just using:

List-Unsubscribe: <mailto:<%@ include option='NmsEmail_DefaultErrorAddr' %>?subject=unsubscribe<%= escape(message.mimeMessageId) %>>

But again the same results. It shows the feedback loop option to unsubscribe in Gmail but not working in Hotmail/ Outlook...

1543641_pastedImage_7.png

Is there anything else to try and test? I have also noticed that the same code is working for Gmail AND hotmail in:

version 6.1.1 build 8883 - App server build 8850

and not in

version 6.1.1 build 8883 - App server build 8797

Could this be causing this issue?

Kind regards,

Majid Awan

davidk21713691

19-10-2017

Carlota,

List-Unsubscribe: <mailto:<%@ include option='NmsEmail_DefaultErrorAddr' %>?subject=unsubscribe<%= escape(message.mimeMessageId) %>>

Cpy and paste the code above under your SMTP tab.

Thanks

David

CIGM

19-10-2017

Hi David,

Thanks fro your reply too.

I have followed your advise and it's not working so I must be doing something wrong.

See screenshot below:

1328004_pastedImage_0.png

Questions:

- The mailto: needs to go to unusubscribe@domain.com or needs to be substituted by another email address?

- I have tried to paste the unsubscribe webapp public URL instad of the encrypted preloading link but is not working neither.

When I sent an email and I checked it out in Outlook, the link it's not showing and I am still having the option to mark as a spam.:

1328005_pastedImage_1.png

And same on Gmail:

1328009_pastedImage_2.png

Any further help, would b appreciate it (trying to fix this for two days and can't get it to work!)

Best,

Carlota

davidk21713691

18-10-2017

Microsoft recently confirmed changes to how they support the list-unsubscribe header in their webmail interfaces, and now only accept the mailto URI. While Gmail will honor either the http or the mailto URI.

Try this

List-Unsubscribe: <mailto:<%@ include option='NmsEmail_DefaultErrorAddr' %>?subject=unsubscribe<%= escape(message.mimeMessageId) %>>

or what I have in the screenshot attached.

1327192_pastedImage_2.png

Both are working for me.

David

CIGM

18-10-2017

Hi David,

I'm trying with Outlook webapp. Could it be that the unsubscribe link is wrong? I never had an issue when I did it on my previous company... literally been trying the whole day and the link is not showing up!

Best,

C

davidk21713691

18-10-2017

Carlota,

Which ISPs are you using for your testing?

If gmail, please check your email original to see if you have the list unsubscribe.

Even if an email messages includes a list-unsubscribe header, Gmail's user interface will not display the "unsubscribe" link if Google believes the sender's reputation is poor.

You can try with Outlook and Yahoo also.

Thanks.

David