Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Facebook sync on adobe campaign not working

prabhakaranv572
Level 1
Level 1

When i create the facebook external account on adobe campaign it showing the error like "Application id or secret key are not recognized by facebook".but my application id and secret key is copied from facebook only.What i did wrong please help me.Please refer the attachment for your referenceError.png

1 Accepted Solution
florentlb
Correct answer by
Level 10
Level 10

Ok, so it seems your build is pretty old and does not reflect the current way Facebook's API works.

You can have a look at the Campaign release notes here: Adobe Campaign Release Notes

By searching for "social", you will see that some builds more recent than yours contain fixes related to Facebook's API evolution.

I would recommend upgrading to a more recent build, by reaching out to your IT department if you are on-prem or to Campaign support team if you are hosted.

Hope this helps,

Florent.

View solution in original post

6 Replies
florentlb
Level 10
Level 10

Hi,

Which build are you using? I know that there were some fixes made to the facebook connector in recent builds (since mid-2016).

Have you checked the documentation? Screenshots may not be up to date regarding latest Facebook changes but the overall configuration should be still pretty the same: Creating a Facebook application

Let me know,

Florent.

prabhakaranv572
Level 1
Level 1

Hi florentlb,

Thanks for your reply. I have used the following build and version of adobe campaign

Version 6.1.1 build 8665 of 07/10/2015

(Application server : version 6.1.1 build 8653)

And I have also followed the your mentioned Creating a Facebook application document only.

Regards,

Prabhakaran.v

florentlb
Correct answer by
Level 10
Level 10

Ok, so it seems your build is pretty old and does not reflect the current way Facebook's API works.

You can have a look at the Campaign release notes here: Adobe Campaign Release Notes

By searching for "social", you will see that some builds more recent than yours contain fixes related to Facebook's API evolution.

I would recommend upgrading to a more recent build, by reaching out to your IT department if you are on-prem or to Campaign support team if you are hosted.

Hope this helps,

Florent.

View solution in original post

prabhakaranv572
Level 1
Level 1

Thank you florenttlb.

May I know which adobe campaign build and server version onwards support latest facebook API.

Regards,

Prabhakaran.v

florentlb
Level 10
Level 10

Hi,

I'd suggest at least 8770, considering that the release notes don't mention any specific fix related to Facebook from this build.

In any case, the latest build is often the most up to date when it comes to third party support.

Hope this helps,

Florent.

florentlb
Level 10
Level 10

Hi,

Were you able to upgrade and try with a more recent build?

Let me know,

Florent.