Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Exception raised in Adobe Campaign Standard when viewing Profile

robertk9151071
Level 2
Level 2

Hello,

Does anyone has faced with issue related exception, when viewing profile details  in ACS. ACS throws  exception:

The object which you are trying to access is either unavailable or you don't have the required rights to view it. Cannot calculate the resource for '/head/marketingHistory/

FYI. I am having highest administrator rights on server.

Thanks

1 Accepted Solution
shrawans3153003
Correct answer by
Employee
Employee

Hello Robert,

We have seen similar issue and the cause of this error is usually that a custom resource was being used along with a manual join vs the Auto PK.  There could be some profiles that don't not have that custom resource defined.  This usually resolved by rebuilding and relinking the custom resource. You can check either the profiles need to be linked to the custom resource correctly or the resource should be removed.

  • Take a look at the custom resources under Administration > Development.
  • In custom resources, check if there are any links to "profile" using manual join conditions (not using the auto pk but some custom fields)
  • If there is then the profiles which don’t have this custom resource defined will show the error.
  • We need to link custom resources to that profile to fix this issue.

View solution in original post

2 Replies
shrawans3153003
Correct answer by
Employee
Employee

Hello Robert,

We have seen similar issue and the cause of this error is usually that a custom resource was being used along with a manual join vs the Auto PK.  There could be some profiles that don't not have that custom resource defined.  This usually resolved by rebuilding and relinking the custom resource. You can check either the profiles need to be linked to the custom resource correctly or the resource should be removed.

  • Take a look at the custom resources under Administration > Development.
  • In custom resources, check if there are any links to "profile" using manual join conditions (not using the auto pk but some custom fields)
  • If there is then the profiles which don’t have this custom resource defined will show the error.
  • We need to link custom resources to that profile to fix this issue.

View solution in original post

BraullioSoares
Level 3
Level 3

Hi shrawans315300

I am facing the same issue that is described above. I see that the solution would be to link a custom resource to profiles with that issue. Could you please explain how we perform that?

Thanks in advance,

Regards.